[coreboot] Asus M2A-VM

Bao, Zheng Zheng.Bao at amd.com
Thu Dec 18 02:57:47 CET 2008

Adjust rom_table_end from 0x000f34d0 to 0x00100000
uma_memory_start=0x78000000, uma_memory_size=0x8000000 Wrote coreboot
table at: 00000530 - 00000778  checksum 5730 ..

Based on your bootlog, coreboot correctly detects your memory
size(uma_memory_start+ uma_memory_size). When does it report 2G memory?


-----Original Message-----
From: coreboot-bounces at coreboot.org
[mailto:coreboot-bounces at coreboot.org] On Behalf Of Carl-Daniel
Sent: Wednesday, December 17, 2008 12:14 PM
To: Coreboot
Subject: Re: [coreboot] Asus M2A-VM

On 17.12.2008 04:39, Carl-Daniel Hailfinger wrote:
> Hi all,
> my Asus M2A-VM (690G/SB600) is working and boots to memtest and FILO.
> Memtest works fine over serial (well, I only ran memtest until it
> reached 15%).
> FILO can load the kernel, but I didn't have time to enable serial
> for my kernel.
> Thanks to Zheng Bao for adding support for my 690G graphics.
> I'll post a patch soon. Right now, there are a few more bugs to fix.
> ncHT fixup is already known, a clean patch will come tomorrow.
> On a first boot, I get an endless loop of
> drive detection fail,trying...
> until I press the reset button. After that, it boots fine. That
> is in the SB600 code. I will enable some debugging that was disabled
> revision 3785.
> Another curiosity is that my power button has become ineffective. It
> simply initiates a reboot instead of switching off the machine after 4
> seconds. That happens only with the FILO payload.

Oh, and it does not find more than 2 GB of RAM. I'll try to debug that
as well.

Right now, I'm happy that it gets to FILO and can load a kernel.

The interrupts are probably wrong. I need to check that.



coreboot mailing list: coreboot at coreboot.org

More information about the coreboot mailing list