[coreboot] [RFC] Error out on implicit declarations

Corey Osgood corey.osgood at gmail.com
Fri Dec 19 20:16:55 CET 2008

On Fri, Dec 19, 2008 at 1:19 PM, Joseph Smith <joe at settoplinux.org> wrote:

> On Fri, 19 Dec 2008 11:16:19 -0700, "Myles Watson" <mylesgw at gmail.com>
> wrote:
> > On Fri, Dec 19, 2008 at 11:03 AM, Joseph Smith <joe at settoplinux.org>
> wrote:
> >
> >>
> >> Arrh,
> >> Looks like both of the 82830 boards are broken. What do I need to do to
> > fix
> >> them?
> >>
> > Do they still break after my last two patches?  I thought they were
> fixed.
> >
> I was going by Corey's last abuild log. I appologize if you have fixed them
> since then.

 rca/rm4100 is  still broken. All you should need to do is check that all
the functions are properly declared, either by including their declarations
in a header or an extern(al) declaration. Making the change in Carl-Daniel's
patch will tell you very quickly if you got them all or not ;)

Myles, those patches when applied with Maggi's break the amd pistachio and
dbm690t. New abuild log with all 6? patches applied. I accidentally ran it a
second time and lost the original log, so don't mind the "previously ok"
comments, those boards were actually rebuilt and succeeded once.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20081219/5db0fe59/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 2nd_abuild_run
Type: application/octet-stream
Size: 60186 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20081219/5db0fe59/attachment.obj>

More information about the coreboot mailing list