[coreboot] patch: init gx cache earlier.

Marc Jones Marc.Jones at AMD.com
Wed Feb 6 02:55:36 CET 2008

Carl-Daniel Hailfinger wrote:
> On 06.02.2008 02:38, Marc Jones wrote:
>> Carl-Daniel Hailfinger wrote:
>>> pre_payload() is not board specific, but Geode LX-specific.
>>> geodelxinit.c may be a more appropriate location.
>> Correct, but I foresee other non-Geode platforms needing a call just
>> prior to the payload running but I am flexible on this.
> Sorry, I didn't express clearly enough what I wanted. I just tried to
> avoid duplication if this specific version of pre_payload() in mainboard
> code and hoped to have the code of this pre_payload() in geodelxinit.c.
> Maybe rename it to platform_pre_payload() and have it called by
> pre_payload() inside mainboard specific code. That would give us all the
> flexibility with minimum code duplication.
> Regards,
> Carl-Daniel
Good point. I will fix this.

Marc Jones
Senior Firmware Engineer
(970) 226-9684 Office
mailto:Marc.Jones at amd.com

More information about the coreboot mailing list