[coreboot] [PATCH] [RFC] v3: CS5536 cleanup, and v3 design

Stefan Reinauer stepan at coresystems.de
Fri Jul 4 00:21:29 CEST 2008

Carl-Daniel Hailfinger wrote:
> OK, that one is indeed valid. However, I'd like to keep the number of
> dev_find_*_device calls as low as possible without compromising code
> readability.
> For example, if you want to establish a link between two devices,
> calling the function with device pointers for both devices would make
> the code readable and stuff would still work.
Hmm... and we can describe those links between devices in the dts.. I 
think we tried that for HT once.

So we'd have a construct of "devices" and a construct of "links" which 
are connections between devices.

links would have enable, disable, reset(, probe?) as methods?

coresystems GmbH • Brahmsstr. 16 • D-79104 Freiburg i. Br.
      Tel.: +49 761 7668825 • Fax: +49 761 7664613
Email: info at coresystems.dehttp://www.coresystems.de/
Registergericht: Amtsgericht Freiburg • HRB 7656
Geschäftsführer: Stefan Reinauer • Ust-IdNr.: DE245674866

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 249 bytes
Desc: OpenPGP digital signature
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20080704/4ab34a85/attachment.sig>

More information about the coreboot mailing list