[coreboot] [PATCH] [RFC] v3: CS5536 cleanup, and v3 design

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Fri Jul 4 00:25:22 CEST 2008

On 04.07.2008 00:21, Stefan Reinauer wrote:
> Carl-Daniel Hailfinger wrote:
>> OK, that one is indeed valid. However, I'd like to keep the number of
>> dev_find_*_device calls as low as possible without compromising code
>> readability.
>> For example, if you want to establish a link between two devices,
>> calling the function with device pointers for both devices would make
>> the code readable and stuff would still work.
> Hmm... and we can describe those links between devices in the dts.. I
> think we tried that for HT once.
> So we'd have a construct of "devices" and a construct of "links" which
> are connections between devices.
> links would have enable, disable, reset(, probe?) as methods?

Great idea!

Funny side note: I spent the last 9 months working on link/device model
representation with dependencies for my diploma thesis. This will be an
exciting way to cross-check the stuff I developed in a totally different



More information about the coreboot mailing list