[coreboot] SeaBIOS debug output

Myles Watson mylesgw at gmail.com
Fri Jul 18 18:07:59 CEST 2008

> -----Original Message-----
> From: Tom Sylla [mailto:tsylla at gmail.com]
> Sent: Thursday, July 17, 2008 6:04 PM
> To: Myles Watson
> Cc: Kevin O'Connor; Coreboot
> Subject: Re: [coreboot] SeaBIOS debug output
> On Thu, Jul 17, 2008 at 12:40 PM, Myles Watson <mylesgw at gmail.com> wrote:
> > Here are the two logs for the Windows XP install CD.  I'm wondering if
> > we should make SeaBIOS pretend to be an older BIOS and see what
> > happens.  It seems like there was some structure that is returned on a
> > BIOS call that tells what version it is.
> >
> > I used to be able to make it through the install process with ADLO
> > (just rombios.c, not rombios32.c), so maybe something in the PCI code
> > is messing me up.
> >
> > I don't know what else to try.  Hopefully you can spot something in the
> logs.
> Could you try what Kevin did, and install XP on your factory BIOS
> (ideally with ACPI disabled) and then try and boot that image with
> SeaBIOS?

How do you disable ACPI?  The only reference I found said to write to a file
on the CD and change the option.  There must be another way, right?

> From going through a few x86 cpu and chipset turn-ons, I know that in
> general, debugging OS boot of a full installation is usually much
> easier than trying to debug the installation process of an OS. There
> are less obstacles to booting an already-installed image, and there
> are much more tools available for debugging the aleady-installed OS.
> Once you get that working, you can go back to debugging the CD.

I thought XP was picky about the BIOS, and if you upgraded the BIOS you
frequently had to reinstall.  That's part of the reason I wanted to try the
fresh install.

> It would be interesting to see if your platform has the same sort of
> success that Kevin got on the epia. Maybe your different graphics
> controller will work even better.

I'll try it.  My machine came with LinuxBIOS installed, so I don't have a
"factory BIOS."  I'm trying to figure out how to get one out of a .wph file


More information about the coreboot mailing list