[coreboot] Black window when running qemu with coreboot+LegacyBIOS

Jordan Crouse jordan.crouse at amd.com
Mon Jun 23 18:32:30 CEST 2008

On 23/06/08 18:26 +0200, Stefan Reinauer wrote:
> Jordan Crouse wrote:
> > On 23/06/08 10:14 -0600, Myles Watson wrote:
> >   
> >>>> You have succesfully launched LegacyBIOS.  However, the vga rom was
> >>>> not found.  Make sure you're running with the latest vgabios.  Also,
> >>>> you probably haven't specified a floppy, hard drive, or cdrom to boot
> >>>> from.
> >>>>         
> >>> We should discuss what needs to be done to bring this goodness to
> >>> buildrom.
> >>>       
> >> I submitted a patch a while ago.  After Uwe's suggestions, the only response
> >> I got was from Peter saying that Kevin should decide on the name before we
> >> committed it.
> >>     
> >
> > Ugh - where was I?  Please send it again - We can fight the name battle
> > later.
> >   
> Please, before we get this into buildrom, let's get it straight first. 
> Zhang Rui is working on integration of LegacyBIOS for all purposes, not 
> just int19 booting. It will replace a lot of code in current coreboot. 
> We should consider keeping it in util/ in the v3 tree.

I'm not sure what that has to do with the price of tea in China.  Does
it build seperately from coreboot or not?  If it does, then it belongs in
buildrom.  We can always change what it is named or where it lives later.


Jordan Crouse
Systems Software Development Engineer 
Advanced Micro Devices, Inc.

More information about the coreboot mailing list