[coreboot] help with win-xp and legacybios/coreboot

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sun Jun 29 16:16:05 CEST 2008

Hi Kevin,

On 28.06.2008 19:45, Kevin O'Connor wrote:
> I have successfully installed and booted win-xp with coreboot-v2 and
> legacybios under qemu.


> Unfortunately, when I try to install or boot
> win-xp with coreboot-v2 and legacybios on my via epia-m the system
> hangs.

Hm. Off the top of my head, I see a few things you could try in order of
increasing difficulty:
- Linux installation CD in VESA 640x480x8 mode (e.g. openSUSE install
DVD with graphical boot screen)
- XP installation CD with slipstreamed SP3
- Win2000 installation CD with slipstreamed SP4
- XP (64bit) installation CD with and without slipstreamed SP3
- Vista both 32bit and 64bit (IIRC Vista 64bit was running under
coreboot in Qemu last year)
- Compare factory BIOS memory maps with your memory maps
- Compare lspci (there have been interesting differences in the past)
- Compare IRQ setup (IIRC Windows expects all interrupts to be enabled,
Linux does not care)
- Switch off debugging (might upset Windows)
- Check SuperI/O differences, especially anything with interrupts and timers
- Make sure there is no MP table in memory

> At this point, I don't know if the problem is related to coreboot and
> its epia-m support, or if it is related to legacybios.  I've confirmed
> that the hang does not occur inside the bios.  The last thing the
> install reports before hanging is "Setup is starting Windows".

A few hopefully useful links:

I hope this helps.



More information about the coreboot mailing list