[coreboot] Need help with VGA on epia-m

aaron lwe aaron.lwe at gmail.com
Tue May 27 03:50:33 CEST 2008

On Tue, May 27, 2008 at 12:30 AM, bari <bari at onelabs.com> wrote:
> The Epia-CN (C7+cn700+vt8237r) is having the exact same issue even though it
> is using a more recent VIA chipset. Epia-M9000 (C3 + CLE266 + vt8235). This
> lack of Console VGA issue was next on the list after I clear up some IRQ
> issues with the CN.
> What are we missing for VIA chipsets with integrated video to bring up
> Console VGA?

I have no problem to bring up vga console, I remembered your last mail
mentioned once you load vgabios and bochs bios you'll get vga work but
have problem with usb, I admit that's a problem that the vga card's
irq get misassigned.

> Config.lb in targets/via/epia-cn has:
> cat vgabios bochsbios coreboot.rom > coreboot.rom.final
> option ROM_SIZE=512*1024 - 64*1024 - 64*1024
> Yet I get the same results with VGA if BOCHS is not included. BOCHS does not
> seem to have an effect on X sever and VGA.

If you do not include bochs, vgabios should bail out ;-)

> cat vgabios coreboot.rom > coreboot.rom.final
> option ROM_SIZE=512*1024 - 64*1024
> -Bari

I think epia-m is kind of different, I remember when I first learned
linuxbios, I'm trying to boot the epia-m then and I have exactly the
same problem. Th solution seems to be first set CONFIG_PCI_ROM_RUN=0
and CONFIG_CONSOLE_VGA=0 in Option.lb and build, then change the
values to be 1 and rebuild without deleting the target directory. I
cannot find the original post that presented this solution in the
mailing list now, sorry.


More information about the coreboot mailing list