[coreboot] [PATCH] artecgroup/dbe61: Set up 4MB mode for LPC dongle

Mart Raudsepp mart.raudsepp at artecdesign.ee
Wed May 28 03:04:45 CEST 2008

> On Tue, May 27, 2008 at 5:41 PM, Mart Raudsepp
> <mart.raudsepp at artecdesign.ee> wrote:
>> I don't quite remember what was wrong in my testings before. I just
>> updated to HEAD, compiled and it worked as shown at
>> http://www.pastebin.ca/1031398
> it's got the alix1c memory settings in it from my port :-)
> The files from alix1c are the same.

Oh? I thought we got something based on the memory chip specs. Someone
will have to work on making these optimal at some point anyway.
I do have memtest errors in two specific memory addresses, which haven't
surfaced with a known good coreboot-v2 based firmware, but it's still
chugging along here with it.

> I have no grafix from dbe62 at present. Don't know why.

How about coreinfo as payload with libpayload configured to Geode Video
support? That's the only video output I've gotten as well. lxfb doesn't
work with 2.6.25 (with any BIOS firmware) for me, and I haven't gotten to
try 2.6.24 with v3 yet. Launching X with native driver (xf86-video-geode
is the minimal that can work with coreboot) leads to kernel oopses as
mentioned many times before, possibly involving mfpgt (or some other
ordering of those letters :).
Regular console obviously doesn't work, as there is no VGA BIOS running,
and it seems there's quite some resistance to get that added in too
All the other problems I've noted before (thread titled "DBE62 status")
were noticed over a ssh session, with kernel spitting to serial console
(where the oopses were visible).

Mart Raudsepp

More information about the coreboot mailing list