[coreboot] Coreboot on Tyan S2892

Anose, Bijoy K (N-Aerotek) bijoy.k.anose at lmco.com
Thu Nov 20 18:24:42 CET 2008

Yes, it is busybox-based, and yes, the final kernel is definitely
getting run, as evidenced by 'uname -a' output at the busybox
prompt.  The file '/dev/sda' does exist.. I don't remember the
major/minor numbers, etc.
My .config file is attached.  I am not modifying the skeleton/* files.


	From: Myles Watson [mailto:mylesgw at gmail.com] 
	Sent: Wednesday, November 19, 2008 3:24 PM
	To: Anose, Bijoy K (N-Aerotek)
	Cc: Ward Vandewege; Coreboot
	Subject: Re: [coreboot] Coreboot on Tyan S2892

	On Wed, Nov 19, 2008 at 2:12 PM, Anose, Bijoy K (N-Aerotek) <
bijoy.k.anose at lmco.com> wrote:

		I enabled the busybox option and used the default value
of "5 second pause to allow access to busybox" but it doesn't
		pause anywhere, as far as I can tell.  Coreboot starts,
LAB starts, LAB kexecs the kernel/initrd on the SATA disk, and
		then at that busybox prompt, I get no output when I
issue "fdisk -l /dev/sda".

	So your kernel/initrd is busybox-based as well?  Is the new
kernel really getting run?
	I'd start with ls -l /dev/sda or something simple like that.

		Could you send me a tarball of your buildrom-devel?

	Since it's old I don't think that would be really helpful.  Are
you changing the .config files?  Are you changing the skeleton/ files?

		  Something must be different in our config.  Also your
lab.conf and
		the kernel/initrd that is on your SATA disk, if that
would ok.

	I don't have that machine up right now, so it would take a
while.  I think there's a shorter path to the answer than that.

		I built my own static kexec and xfer'd it to the SATA


		Multiple drives shouldn't make any difference -- if the
controller can see one drive, it can see them all (if it is actually
		working properly). 

	You're right.  If they don't all work it's a bug.  Maybe it's
been fixed.  If you're only using two drives, though, it's probably not

		My system may have 2 drives or 8, depending on its
function.  The one I'm currently experimenting 

		with has only 2 installed.

		(sorry again for top-posting, Outlook is acting
differently over VPN/rdesktop for some reason)


			From: Myles Watson [mailto:mylesgw at gmail.com] 
			Sent: Wednesday, November 19, 2008 11:19 AM 

			To: Anose, Bijoy K (N-Aerotek)
			Cc: Ward Vandewege; Coreboot 

			Subject: Re: [coreboot] Coreboot on Tyan S2892

			On Wed, Nov 19, 2008 at 9:40 AM, Anose, Bijoy K
(N-Aerotek) <bijoy.k.anose at lmco.com> wrote:

				> From: Ward Vandewege [mailto:
ward at gnu.org]
				> Sent: Thursday, November 13, 2008 6:56
				> To: Anose, Bijoy K (N-Aerotek)
				> Cc: Myles Watson; Marc Jones; Coreboot
				> Subject: Re: [coreboot] Coreboot on
Tyan S2892
				> On Thu, Nov 13, 2008 at 07:04:49PM
-0500, Anose, Bijoy K
				> (N-Aerotek) wrote:
				> > > So far it's just me seeing that,
on one specific board
				> (s2891). So
				> > > don't worry about that too much
just yet.
				> >
				> > True, I'll cross that bridge when I
get there.
				> >
				> > First I'll need to be able to boot,
period.  So far, what
				> I've done is
				  > > this:
				> >
				> > 1.  Subversion checkout of latest
buildrom 2.  make menuconfig,
				> > specifying Tyan S2892, 32-bit LAB 3.
				> >
				> > Do I need to do further
configuration (Config.lb etc)?  I
				> thought that
				> > the menuconfig took care of
everything.  Maybe that was wishful
				> > thinking..
				> It's not. The only other thing you
need to do is *pre*pend
				> the vga image to the generated image,
which will generate an
				> image that is exactly 1024KB large,
and which you can flash,
				> and which *should* just boot your
				I finally got coreboot+LAB to boot my
target kernel/initrd on the SATA
				disks (many thanks to Ward)!
				However, once the init script in the
initrd attempts to assembly the
				RAID, it fails because it can't see the
SATA disks.

			How many do you have?  Ward has seen a problem
with some disk controllers not functioning on the ck804.  I've never
used more than one.

				My guess is that coreboot is originally
doing some low level block reads
				the disk to load the kernel/initrd but
when the final kernel attempts to
				do a
				SATA read from the disk, the controller
has not been fully/properly
				and it fails.

			Have you tried configure the busybox shell to
not load automatically, and looked at the SATA drives from there?

				I assume that whatever modifications
that Myles made to successfully
				boot from
				SATA devices with coreboot+LAB on S2892
have trickled down to buildrom..

			I used buildrom.  I think the multiple drives
may be getting you, though. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20081120/25870fa3/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dot-config
Type: application/octet-stream
Size: 2413 bytes
Desc: dot-config
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20081120/25870fa3/attachment.obj>

More information about the coreboot mailing list