[coreboot] alix.2c3 stops at mainboard_pre_payload: done

Roman Yeryomin leroi.lists at gmail.com
Thu Oct 9 23:10:15 CEST 2008

On Thu, Oct 9, 2008 at 11:20 PM, Peter Stuge <peter at stuge.se> wrote:
> Roman Yeryomin wrote:
>> >> what could be the problem?
>> >
>> > My 1c has the serial port on a superio chip. I recognize this
>> > problem from other boards. I also have a 3c3 where I saw this
>> > before I fried the 5536 ATA driver.
>> Sorry didn't understand what you actually mean here... that I have
>> fried my hardware?
> Sorry! No not at all!
> The serial port on alix1c is on the Winbond superio chip. The alix2
> and 3 boards do not have this superio chip and their serial port is
> connected directly to the 5536 - and this is probably the reason that
> serial doesn't work anymore.

that's interesting.. but seems like kernel correctly detects ttyS0 and
spits it's messages to it

console [tty0] enabled
console [ttyS0] enabled
Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing disabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a NS16550A

but after init starts it doesn't work anymore :(
devise is present:
ls -la /dev/ttyS0
crw-rw-rw-    1 root     root       4,  64 Oct  9 21:06 /dev/ttyS0

any clue how I can get it working?

> The 5536 port shall of course work too, but the Winbond chip is much
> more common.
> I only meant that I haven't spent any time on my 3c3 board since I
> fried it.

hmm.. sad..

> Sorry for the confusion!

that's ok
I sometimes do not understand english quite well ;)
I've checked with native bios -- works fine


More information about the coreboot mailing list