[coreboot] ### ALDO Windows Coreboot

Steve Spano steve at fl-eng.com
Sat Oct 11 21:13:26 CEST 2008

I switched to the new download of SEABIOS and am using the amd_vsa_lx.bin
vsa bios from the AMD website posted in Jan 2008.
With corebootv3 + seabios, I can boot into my 1GB Compact Flash with Linux
(which is what I was doing with corebootv2).
However, I am trying to boot to a CDROM so I can load Windows2000 onto a 4GB
compact flash card. This doesnt appear to be working yet.
Booting to a known good hard disk with a WIndows XP image doesnt work
I get here
Start bios
i8042 timeout on wait write
bios_table_addr: 0x000ff0a5 end=0x000ff841
Scan for VGA option rom
Found option rom with bad checksum: loc=000c0000 len=32768 sum=00000010
Turning on vga console
BIOS - begin
e820 map has 4 items:
  0: 0000000000000000 - 000000000009fc00 = 1
  1: 000000000009fc00 - 00000000000a0000 = 2
  2: 00000000000f0000 - 0000000000100000 = 2
  3: 0000000000100000 - 000000000f7e0000 = 1
bios_table_cur_addr: 0x000ff0f5
ata0-0: PCHS=16383/16/63 translation=lba LCHS=1024/255/63
ata0 master: HTS541020G9AT00 ATA-6 Hard-Disk (19077 MiBytes)
ata0  slave: Unknown device
Scan for option roms
Press F12 for boot menu.
Changing serial settings was 00000003/00000002 now 00000003/00000000
enter handle_19:
Booting from Floppy...
fail check_drive:385(00000080):
  a=00000201 b=00000000 c=00000001 d=00000000 si=00000000 di=00000000
  ds=00000000 es=000007c0 ip=0000e7e9 cs=0000f000 f=00000002 r=0000f70c
Boot failed: could not read the boot disk
enter handle_18:
Booting from CD-Rom...
not implemented for non-ATAPI device
atapi_is_ready returned -1
CDROM boot failure code : 00000003
Boot failed: could not read the boot disk
enter handle_18:
Booting from Hard Disk...
Booting from 00000000:00007c00
enter handle_12:
  a=00000000 b=00000000 c=00000000 d=00000080 si=00002118 di=00004c18
  ds=00000000 es=00000000 ip=000024f2 cs=00000000 f=00000297 r=00001fd2
enter handle_12:
  a=00000000 b=00000000 c=00000000 d=00000080 si=00002118 di=0005aa80
  ds=00000000 es=00000000 ip=00008a2c cs=00000000 f=00000297 r=00001fd2
fail get_device:608(00000001):
  a=00004100 b=000555aa c=0005aae4 d=0005aa81 si=00000000 di=0005aa80
  ds=00000000 es=00000000 ip=000088aa cs=00000000 f=00000246 r=00001fd2
fail get_device:608(00000001):
  a=00000800 b=0005aae4 c=0005aae4 d=0005aa81 si=00000000 di=0005aa80
  ds=00000000 es=00000000 ip=00008912 cs=00000000 f=00000246 r=00001fd2
fail handle_15XX:308(00000086):
  a=000000c0 b=00000000 c=0005aa03 d=0005aa81 si=00000000 di=0005aa80
  ds=00000000 es=00000000 ip=00008ae1 cs=00000000 f=00000246 r=00001fd2

Seems to find a VGA ROM, with a checksum issue? Is this right?
Then looks like it tries to boot to the HDD or CDROM but the system freezes.
Any ideas?

Steve Spano, President

Finger Lakes Engineering


-----Original Message-----
From: coreboot-bounces at coreboot.org [mailto:coreboot-bounces at coreboot.org]
On Behalf Of Myles Watson
Sent: Friday, October 10, 2008 4:25 PM
To: steve at fl-eng.com
Cc: coreboot at coreboot.org
Subject: Re: [coreboot] ### ALDO Windows Coreboot

On Fri, Oct 10, 2008 at 1:10 PM, Steve Spano <steve at fl-eng.com> wrote:

Hi Folks,
I have an AMD LX800 custom board running coreboot v2 and linux just fine.
We may now want to use coreboot to boot a Windows2000/XP. I have traced
through the FAQ/lists and assembled this
1) ALDO embedded with CorebootV3
2) Merged in the LX VGA ROM file (64KB) into the blob/vsa folder

When you say you're using ADLO that means you're not using SeaBIOS?  If
you're using the ADLO from the v2 util folder, it's out of date.  The
timeouts are too short for any drive with today's processor speeds.

My goal right now is to have it recognize a CDROM, install Windows to a 4GB
Compact Flash (as an IDE slave), and then boot onto the CompactFlash as
I cannot seem to get the CDROM to boot. Nor can I get the comapct flash,
with a known good linux image, to boot.
I get all the way into ALDO during boot, ALDO finds the CDrom/CF but then it
seems like it has some issue scanning the ATA bus. It says that
"in13_hardisk:function 2 unmapped device for ELDL=80"

This message is benign.  Even when it finds your CDROM you'll see this

Also - I assume that ADLO can boot a linux image as well. I believe that's
what I read?

Should be able to.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20081011/c69b6cd6/attachment.html>

More information about the coreboot mailing list