[coreboot] via vt82c686 southbridge

Stefan Reinauer stepan at coresystems.de
Fri Sep 5 13:11:37 CEST 2008

Daniel Lindenaar wrote:
> Quoting "Stefan Reinauer" <stepan at coresystems.de>:
>> Daniel Lindenaar wrote:
>>> hmmm it's working partly, it seems. First i did something wrong that
>>> skrewed up the com port setup, which I fixed. I now get the debug
>>> messages I added via the serial line, but, strangely, only when i do a
>>> (warm) reboot from a running linux, not with a cold boot...
>> This sounds an awful lot like superio init, or some GPIO issue.
>> Are you initializing your superio correctly? Does your board use the
>> 82c686 superio? Or does it have an extra superio?
>> (Check with superiotool)
>>> probably something needs to be set that doesn't get set by default on
>>> cold reboot.
>>> Anyway, it's the SMBus controller where things go wrong; the log says:
>>> SMBUS controller not found
>> What device are you looking for at that point?
>> On the vt82c686 the smbus device has vendor 0x1106 and device 0x3057
> hmm i'll have to look into the code (at work, now). In linux the
> device is shown as vt82xxx ACPI and power something.. and that device
> includes the SMBus controller at some IO offset. I'm pretty sure I'm
> using the right PCI device, bus maybe the IO offset is wrong.
The message "SMBUS controller not found" implies that the PCI device is
not there. It doesn't even start looking for the offset at that point.

coresystems GmbH • Brahmsstr. 16 • D-79104 Freiburg i. Br.
      Tel.: +49 761 7668825 • Fax: +49 761 7664613
Email: info at coresystems.dehttp://www.coresystems.de/
Registergericht: Amtsgericht Freiburg • HRB 7656
Geschäftsführer: Stefan Reinauer • Ust-IdNr.: DE245674866

More information about the coreboot mailing list