[coreboot] using COM2 on Geode GX-1 system (v2)?

Jonathan Sturges jonathansturges at yahoo.com
Tue Sep 9 05:32:16 CEST 2008

Thanks for the quick reply!
This board uses a National PC97317 Super-I/O chip, and the only reference to a serial port I see in auto.c is a call to function pc97317_enable_serial(), where it passes the value of TTYS0_BASE.  I guess that means something could be wrong with pc97317_enable_serial(), which I'll try to grok tomorrow.


----- Original Message ----
> From: Corey Osgood <corey.osgood at gmail.com>
> To: Jonathan Sturges <jonathansturges at yahoo.com>
> Cc: coreboot mailing list <coreboot at coreboot.org>
> Sent: Monday, September 8, 2008 10:09:09 PM
> Subject: Re: [coreboot] using COM2 on Geode GX-1 system (v2)?
> You also need to change it in the target's auto.c or
> cache_as_ram_auto.c, you'll need to change both the IO base and the
> com port. They're usually defines at the start of the file that you
> have to change.
> -Corey
> On Mon, Sep 8, 2008 at 10:04 PM, Jonathan Sturges
> wrote:
> > Hi,
> > I have a perfectly working coreboot v2 image for a GX-1 target of mine, but 
> when I tried to switch it from COM1 to COM2, I can't make it work.  I thought it 
> would be as easy as updating TTYS0_BASE from 0x3f8 to 0x2f8 in Options.lb, but 
> that doesn't work.  What's the trick to making this work?
> >
> > thanks,
> > Jonathan
> >
> > --
> > coreboot mailing list
> > coreboot at coreboot.org
> > http://www.coreboot.org/mailman/listinfo/coreboot
> >

More information about the coreboot mailing list