[coreboot] unexpected exception errors loading vga rom

Joseph Smith joe at settoplinux.org
Mon Apr 20 18:53:14 CEST 2009

On Mon, 20 Apr 2009 17:50:00 +0200, Stefan Reinauer <stepan at coresystems.de>
> On 20.04.2009 17:38 Uhr, ron minnich wrote:
>> On Mon, Apr 20, 2009 at 8:27 AM, Joseph Smith <joe at settoplinux.org>
> wrote:
>>> Hello,
>>> I keep getting unexpected exception errors on my IP1000 with builds
> over
>>> the past 6 months or so. The unexpected exception errors are random
> errors
>>> and are different every time, but seem to happen right about the time
> the
>>> vga rom loads. I think it has something to do with x86emu and yabel
> loading
>>> the vga rom. If I change it to boot up with out graphics it boots up
> every
>>> time, no problem. If I enable the vga device (2.0) and allocate vga
> memory
>>> but not load the vga rom it boots up every time no problem. So this
> tells
>>> me it doesn’t like something the rom emulator is doing, right? This
> is
>>> very strange because I do not have this problem with the RM4100… just
> the
>>> IP1000 (brother boards).
>> You could well be tickling a but in either emulator. These are hard to
>> find. It's handy to have a user-mode wrapper so you can run these
>> emulators under linux -- much easier to find that way. Is this
>> possible with YABEL?
Could I try something like vbetool?
> Not right now, but you can connect to coreboot via gdb over serial,
> which gives you a user space frontend with single stepping...
Do you mean http://www.coreboot.org/Debugging ??
I tried that, but the errors are different everytime and not always in the
exact place so it is hard to put a finger on it using this method.
Joseph Smith

More information about the coreboot mailing list