[coreboot] SeaBIOS on DBE63 not functional

Mart Raudsepp mart.raudsepp at artecdesign.ee
Wed Jan 28 22:50:43 CET 2009

On K, 2009-01-28 at 13:36 -0500, Kevin O'Connor wrote:
> > handle_08
> That's the timer irq handler.
> So, you're getting interrupts, and it appears grub is running (or at
> least responding to irqs).

duh, I should configure autoboot after some seconds to be there, to
actually see something.

> BTW, what are you using for a vgabios?  I thought geode didn't have a
> vga bios available.

I am not using a VGA BIOS at all. Now I realize I didn't have automatic
boot of a secletion on timeout in my grub.conf, and I need to test if
perhaps linux boot actually works and I can't just continue with that
without a PS/2 keyboard and timeout to automatic choice. I'll report
back on that after I can test it in the office.

XPe boot definitely didn't work then though. It probably does rely on
VGA BIOS at start, but after that the native driver takes over.
However it might also have been something else not being suitable for it
compared to legacy BIOS, e.g ACPI vs non-ACPI installation (our legacy
BIOS doesn't implement ACPI though, iirc).
I'll re-test that after GRUB too, and gather logs as necessary.

Regarding a note in the other reply of yours - no, I don't have any
SuperIO, and therefore no PS/2 keyboard or the like. I only have a USB
keyboard and that I believe is not supported yet by SeaBIOS. I have OHCI
not UHCI, as a non-Intel chipset (unless I'm mixing the two again).

Mart Raudsepp

More information about the coreboot mailing list