[coreboot] [PATCH] Add Mitac 6513WU mainboard support

Uwe Hermann uwe at hermann-uwe.de
Sun Jul 5 21:39:32 CEST 2009

On Sat, Jul 04, 2009 at 05:36:20PM -0400, Michael Gold wrote:
> This patch adds support for the Mitac 6513WU mainboard, a Compaq OEM
> board using the i810 chipset.  Not all hardware has been tested, but my
> test PC boots Linux (via FILO) without any problems.
> The configuration leaves 32 kB for the video BIOS, but the onboard video
> isn't currently working due to known problems with this chipset.
> Signed-off-by: Michael Gold <mgold at ncf.ca>

Great stuff, thanks a lot! This is committed in r4401 with some minor

I dropped all "(C) Uwe Hermann", pretty much all these files are trivial
and/or generic, no need to carry over any (C) lines.

> +    device pci 1.0 on                   # Chipset Graphics Controller (CGC)
> +      chip drivers/pci/onboard
> +        device pci 1.0 on end
> +        register "rom_address" = "0xfff80000" #512k image
> +      end
> +    end

I changed this part a bit, this may be nested a bit too much, but maybe
I'm wrong, not sure. Either way, the version which is in svn now worked
for me on the MS-6178 board, please try a plain svn checkout (r4401) and
see if onboard VGA works (better) on your board.

> +romimage "normal"
> +	option COREBOOT_EXTRA_VERSION = ".0Normal"
> +	payload ../../../../payloads/filo.elf

Changed this to the generic "../payload.elf" we try to use
everywhere now (but there may be more changes wrt to this
when we move to kconfig for v2).

http://www.hermann-uwe.de  | http://www.holsham-traders.de
http://www.crazy-hacks.org | http://www.unmaintained-free-software.org

More information about the coreboot mailing list