[coreboot] [patch] ACPI on m57sli v1.0 - parport interrupt driven

Harald Gutmann harald.gutmann at gmx.net
Tue Jul 7 19:04:30 CEST 2009

On Tuesday 07 July 2009 18:52:43 Andreas B. Mundt wrote:
> Hi,
> >>[...]
> >> 	pnp: PnP ACPI: found 6 devices
> >
> >What option did you set to get pnp messages? acpi=debug?
> No, just default dmesg on debian squeeze.
> So, updated remaining minor issues for the m57sli:
>     * missing power state:
>       	      prop. BIOS:
> 	      	    powernow-k8: 4 : fid 0xa (1800 MHz), vid 0x10
> 	      coreboot: powernow-k8: ph2 null fid transition 0x11
I think that this is not directly M57SLI related. My assumption is, that there 
is some "logical" error in the PowerNow generator which is used to generate 
the P-states on m57sli. I've already looked at the code, and the BKDG, but not 
in the detail which would be necessary to find and fix the mistake.
>     * hda: UDMA/33 compared to UDMA/66 with prop. BIOS
My suggestion would be to open up a new ML-thread according to this problem.
It should be "easy" to fix, and I think that it has nothing to do with the DMA 
modes itself, but with the "88pin-wire-cable-bit" (but I don't know if it's 
for real a bit which needs to be set). I also tried to investigate that 
problem, but ran out of time the evening I started. (check kernel ide-drivers 
amd7xxx.c (or similar) to find out what's going on there).

>     * ??
> Thanks,
> 	Andi
Regards, Harald
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20090707/9efb10b4/attachment.sig>

More information about the coreboot mailing list