[coreboot] SuperIO question

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Wed Jul 29 15:42:59 CEST 2009

Hi Jorge,

On 29.07.2009 10:51, jorgefm at cirsa.com wrote:
> This is my first email to this mailing list. I've joined because I've a 
> little question related to the
> BIOS superio initialization process and I would like to ask to the 
> masters.

We specialize in coreboot related questions, so it's unlikely we can
help you with a BIOS problem unless you want to replace that BIOS with

> I'm developing a little hardware module with a w83627hf superio module.
> This hardware is attached to a com express module. I've found that my 
> hardware is not always initialized
> by the com express BIOS, it depends on the manufacter.
> [...]
> Then, I think that the hardware is working but I need some initialization 
> in the southbridge or something
> else that the first BIOS is doing. Where can I looking for this info? Both 
> com express modules has the intel ICH7-M southbridge.

I'd say the best way forward is to diagnose this with the help of
superiotool. Make sure the w83627hf kernel module is not loaded
automatically, then run superiotool -dV and compare the outputs. If
superiotool finds your SuperIO only on one of the boards, you most
likely have a southbridge resource configuration problem which needs to
be addresses by the BIOS manufacturer (or a custom early kernel driver).
If superiotool finds your SuperIO on both boards, compare the settings
and work from there.



More information about the coreboot mailing list