[coreboot] [PATCH] Table code cleanup

Myles Watson mylesgw at gmail.com
Thu May 14 06:30:09 CEST 2009

> Myles Watson wrote:
> > When you're reviewing, it will be helpful to note that rom_tables_* ==
> > LOW_TABLES, high_tables_* == HIGH_TABLES, and low_tables==
> > coreboot-specific very low tables.
> Maybe they should be renamed to better show what they are.

Yes.  I didn't rename them yet to make it clearer what I changed.  I think
the reason the names are confusing is historical.  I'm not sure why they
were called rom_tables, though.

> > tables.diff:
> > high_low.diff:
> > both.diff:
> >
> > Signed-off-by: Myles Watson <mylesgw at gmail.com>

I'm hoping for a review from Stefan or Patrick because they've been using
the ACPI tables differently than anyone else.  I think I probably broke it
for them, but I'm hoping it will be an easy fix once I understand what they

> Acked-by: Peter Stuge <peter at stuge.se>


More information about the coreboot mailing list