[coreboot] [PATCH] flashrom: Use chipaddr_t instead of volatile uint8_t *

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sat May 16 04:29:14 CEST 2009

On 16.05.2009 04:22, ron minnich wrote:
> anything that doesn't in in _t.

I hate _t as well.

> flashaddr strikes me as a good name.

flashaddr sounds good.

chipaddr is my favourite, though, because our accessor functions are
named chip_read* and chip_write* and this would give us some naming
consistency. Of course, said consistency can also be achieved by
renaming the chip accessor functions to flash_read* and flash_write*.

The name is a not important for me as long as we can kill volatile
uint8_t * with it.

Do you want me to resend, and with which name?


More information about the coreboot mailing list