[coreboot] [flashrom] Write support doesn't work on A7M266-D

Pierre Bogossian bogossian at mail.com
Sat May 16 16:47:56 CEST 2009


in january, I sent a mail to report that I could not flash a Pm49FL002 chip on
my A7M266-D motherboard using flashrom.
Since then, I tried to figure out what was going wrong.
I discovered that the problem comes from the TBL# and WP# pins of the flash chip
that have to be set high to disable write protection respectively on the boot
block and on the rest of the memory (I guess all of you already knew that, but
I'm a noob, so it's new for me).
Flashing the chip using AFLASH, I checked with a voltmeter that the voltage at
the WP# pin is jumping from 0V to 3.3V and then 0V again, every time a block is
written. Doing the same test while flashing with flashrom, the voltmeter reads
0V all the time.
So it seems clear that flashrom is not doing what is needed to set the TBL# and
WP# pins high when a write is done.
Now, I have no idea how to set these pins high. Are these pins controlled by the
AMD-768 chipset ? I searched the documentation provided by AMD but found no
mention about these pins. All I found is that a bit in a register (0x40) has to
be set to enable LPC ROM write, but flashrom is already doing that, so I suppose
it's unrelated to the TBL#/WP# write protection.
Can someone tell me how the voltage of pins TBL#/WP# is controlled ?


Be Yourself @ mail.com!
Choose From 200+ Email Addresses
Get a Free Account at www.mail.com

More information about the coreboot mailing list