[coreboot] #137: S2895 no function after coreboot 2 flash

coreboot svn at coreboot.org
Thu May 21 13:49:49 CEST 2009

#137: S2895 no function after coreboot 2 flash
    Reporter:  anonymous  |          Type:  defect           
      Status:  new        |      Priority:  major            
   Milestone:             |     Component:  buildrom         
     Version:  v2         |      Keywords:                   
Dependencies:             |   Patchstatus:  there is no patch

Comment(by myles):

 Replying to [comment:16 anonymous]:
 > I need a little more help to get this XP working. Could you give a
 helping hand?
 > Is it possible to use the DSDT.dat file that i extracted from my
 original Bios and implement that into the coreboot? Or is this not

 It's possible.  There are a couple of problems:
 1. Buses are renumbered by coreboot
 2. Different Opteron registers are used
 3. Interrupt assignments are different

 I was hoping that the acpica tools and linux firmware kit would help me
 narrow down the problems.  Unfortunately, the ACPI from the factory BIOS
 has errors too, so it is hard to tell what is right.

 I've been thinking about stripping my s2895 down to just one HT link to
 simplify things, so that I could get Windows to work and then add
 functionality back in.  If we disable the 8131 (you lose PCI-X and
 possibly SCSI) and disable the Nvidia 2060 (you lose a PCIe slot and a
 NIC), then there is only one root PCI bus and one APIC.  I think it would
 be doable, but I haven't gotten to it yet.

 I'll help you do it if you are interested.


Ticket URL: <http://tracker.coreboot.org/trac/coreboot/ticket/137#comment:17>
coreboot <http://www.coreboot.org/>

More information about the coreboot mailing list