[coreboot] [PATCH] Major cleanups of hard_reset() related code/config, try 2
uwe at hermann-uwe.de
Sat Oct 24 01:21:10 CEST 2009
On Thu, Oct 22, 2009 at 10:20:32AM +0200, Stefan Reinauer wrote:
> > And then there are various reset.c files in the mainboard directories
> > which don't look board-specific at all. I propose to drop them all and
> > provide one global hard_reset() function somewhere. Feasible?
> It might silently break a lot of stuff. There's about 6 ways to reset a
> machine (probably more) and it's not always trivial to see why a certain
> reset method is needed at a certain time.
OK, we should add comments for this non-obvious stuff then (where we
know the reason at least). I won't touch any of them for now without
> To your patch, I don't understand why you're suggesting to rename
> hard_reset to board_name_hard_reset(). That seems like an awful idea...
> Any reason for it?
It was probably a stupid idea, yes. I removed those comments. The reason
was that we have one i82801ca_hard_reset() function already in
has a hard_reset() function that is a simple wrapper around
i82801ca_hard_reset(). That seems to be the only such function, all
other southbridges name the function hard_reset() already. Maybe
we should rename i82801ca_hard_reset() to hard_reset() and then drop
Either way, this is material for another patch, maybe I'll post
For now I kept the updated hard_reset() patch as simple as possible,
in order to get a first round of cleanups in.
I also left ruik's hard_reset() functions alone for now as Myles
suggested, maybe we should rename soft_reset() to hard_reset() in
that code, not sure.
Updated patch attached.
http://www.hermann-uwe.de | http://www.randomprojects.org
http://www.crazy-hacks.org | http://www.unmaintained-free-software.org
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 36178 bytes
Desc: not available
More information about the coreboot