[coreboot] ASUS M4A77TD-PRO. No boot, nothing on the serial port. I'm quite lost.

xdrudis xdrudis at tinet.cat
Mon Aug 2 15:51:54 CEST 2010

On Mon, Aug 02, 2010 at 11:54:15AM +0200, Rudolf Marek wrote:
> I would suggest to try to make it work with serialICE first, then
> fix the coreboot console as second step. Go to www.serialice.com and
> download it.
> It is some kind of simple monitor which can execute various IO
> operations through serial port.
> I'm attaching a file which could do the trick for you. Set the
> baudspeed to 38400 and select that asrock board in kconfig. Replace
> the existing file with attached, and compile. Not sure if padding is
> there so if you get 64KB image then you need just to place the image
> in last 64KB of the flash.
> Then use minicom or whatever and see if you get the serialice
> prompt. If so, you just need to fix the coreboot to do same thing.

Ok. I did it and I got the serialICE prompt (@38400). In fact it appears again and 
again every second or so. That suggests some watchdog might be rebooting the
board. I already set the it8712f kill watchdog call in coreboot, not sure 
if it was needed, but it seems it is.  I could put it in serialICE but 
unless I need to use SerialICE for something else I think I won't. In fact 
if I had done the qemu part coreboot itself might have reset the wachdog
over the serial line, I guess. 

Thank you very much. Now I'm going to compare what serialICE does with what
coreboot does and see where I get. 

More information about the coreboot mailing list