[coreboot] 440BX - DFI P2XBL - Which Target?

Roger rogerx.oss at gmail.com
Thu Dec 30 05:49:52 CET 2010

On Wed, Dec 29, 2010 at 09:51:55PM -0500, Keith Hui wrote:
>> Believe it or not, tried my old LinuxBIOS2.0.0 build using filo on a softboot
>> (no power off, just reset) and found it booted into filo!
>> Seems it's stalling at raminit on cold boots.  I have a diff of logs just
>> in case anybody's curious.
>Yes, please show us that log. I had a hand in bringing the 440BX ram
>init up to code. :P

OK.  Since you asked for it. I'll email directly to you.  When I diff the two
logs, you can blatantly see lines 59, 64, 70, ... not identical between cold &
warm boots.  And, these lines correspond to the RAM chips initialization.

I'm thinking, as I think as it's been stated in the past 3+ years, get RAM init
corrected and the rest of the hangs might likely resolve themselves.

>> Using the abit/be6-ii_v2_0 target, stalled on INT10
>> Now this is where the fun starts, because I just accidentally flashed the ROM
>> instead of the BIOS Saver device.  ug.
>Ouch. Is the BIOS chip socketed? Is there another machine you can use
>to hot flash the chip?

NP here. I had bios saver installed and just had to refresh myself on how it
works.  I yanked & stored the original 256K BIOS chips and replaced them with
256K purchased from Digikey.  So I use the Digikey as repeatable burn targets
and the bios saver chip for the manufacturers BIOS.  So, when the Digikey burst
into flames, I can just replace with another.  Why wear-out the original part
is what I'm thinking.

>> int10 call returned error.
>> Unknown INT10 function 0e2e!
>> int10 call returned error.
>Build a new image with SeaBIOS as the payload, and have SeaBIOS, not
>coreboot, run the VGA option ROM. The VGA BIOS is calling on some BIOS
>functions that coreboot does not provide. Who knows what will happen.

I do have the prebuilt seabios payload.  I'm troubled as to what "VGA option
ROM" your speaking of.  I'm thinking, the menu option concerning executing VGA
ROM code.  ... i'll fiddle with this and if something gives on a warm boot,
I'll post to the list.

>Maybe you can try starting off from ASUS P2B instead. Same hardware
>mostly, and some ACPI work was done on it recently and we got them to
>sort of work.

I believe one of the asus p2b one(s) is the template I used to get LinuxBIOS
2.0.0 working to boot into filo recently on a warm boot.  Albeit, I likely
swiped the source tree since years ago, but I do have a working bios image
here.  As to which ASUS P2B board it was, I can't recall.

>Hang in there! I'd love to see another 440BX board gaining support.

I also have a BIOS post card installed, but I don't think I need this at the
point I'm at correct?  Is there anything else I can learn/look/research into
on this code?  From what I see at this point, it's just comparing logging &

More information about the coreboot mailing list