[coreboot] YABEL full debug problems

Stefan Reinauer stepan at coresystems.de
Fri Feb 19 20:30:48 CET 2010

On 2/19/10 7:05 PM, Myles Watson wrote:
> I think this meaning of CONFIG_DEBUG should be separate from the other
> instances in the tree.
There are only two, and I think we could / should drop them anyways. But
renaming the YABEL ones is good.

I have another patch in the queue that drops the non-yabel biosemu ....

Maybe we should rename yabel back to bios emulator? or generally
something more meaningful? yet another makes little sense if it's the
only one ;-)

Also CONFIG_DEBUG would applies to the x86emu portion of the code, too.
Not sure if it makes sense to have CONFIG_X86EMU_DEBUG _and_
CONFIG_YABEL_DEBUG and they're in the very same field of what things can
go wrong.

coresystems GmbH • Brahmsstr. 16 • D-79104 Freiburg i. Br.
      Tel.: +49 761 7668825 • Fax: +49 761 7664613
Email: info at coresystems.dehttp://www.coresystems.de/
Registergericht: Amtsgericht Freiburg • HRB 7656
Geschäftsführer: Stefan Reinauer • Ust-IdNr.: DE245674866

More information about the coreboot mailing list