[coreboot] [PATCH]more buildsystem refactoring

Patrick Georgi patrick at georgi-clan.de
Tue Mar 16 13:02:02 CET 2010

Am 16.03.2010 12:57, schrieb Peter Stuge:
> Haha, wow, that really looks, interesting.. Not at all saying there's
> any better way.
Main advantage: a single rule that covers gcc invocations

Main disadvantage: Three levels of variable expansion ($, $$, $$$$)

Given that few people need to touch this, I considered the trade-off to
be okay.

>> - Report build of failover.inc and romstage.inc
> Are these built into assembly files? Are those files named .S?
> What does .inc mean?
Maybe they really should be called .S, as that's what they are. We use
.inc by convention for assembly files that are supposed to be _inc_luded
into some larger form (mostly by crt0_includes.h)

>> Signed-off-by: Patrick Georgi <patrick.georgi at coresystems.de
> Acked-by: Peter Stuge <peter at stuge.se>
Thanks, r5224


More information about the coreboot mailing list