[coreboot] PCI register read/mod/write code

Peter Stuge peter at stuge.se
Mon Oct 4 07:03:41 CEST 2010

Warren Turkal wrote:
> I am sure this it bike shedding, but here are a few other options for
> the name scheme:
> * pci_bit_and8()
> * pci_bitwise_and8()
> * pci_bit_andb()
> * pci_bitwise_andb()

Don't like _set and _clear at all?

> I am waffling between preferring pci_bitwise_andb() or
> pci_bitwise_and8() for readability.

I think it's a good idea to be consistent with the other functions,
which are all using the numeric size.


More information about the coreboot mailing list