[coreboot] [PATCH try 2] Reduce duplicate definition in CAR code.
wt at penguintechs.org
Thu Oct 7 09:23:38 CEST 2010
With regard to mtrr_def.inc instead of the header, I would still need
to create an asm macro so that they could be put in the file where
desired. Would it be better to have a separate include mtrr_def.inc
instead of just including it in the x86/mtrr.h header?
On Wed, Oct 6, 2010 at 10:23 AM, Uwe Hermann <uwe at hermann-uwe.de> wrote:
> On Wed, Oct 06, 2010 at 06:51:13AM -0600, Myles Watson wrote:
>> > + /* fixed mtrr MSRs */
>> > + .long MTRRfix64K_00000_MSR
>> > + .long MTRRfix16K_80000_MSR
>> > + .long MTRRfix16K_A0000_MSR
>> I'm fine with replacing the magic numbers, but moving the lists to ASM
>> macros in C header files, when they're only used in this one place,
>> doesn't make sense to me.
> They're only used once per cache_as_ram.inc file, but every such file
> has that list, so putting the list in an mtrr_defs.inc or the like
> and using ".include mtrr_defs.inc" in every cache_as_ram.inc would
> be nice IMHO.
> http://hermann-uwe.de | http://sigrok.org
> http://randomprojects.org | http://unmaintained-free-software.org
More information about the coreboot