[coreboot] Successful boot on Gigabyte GA-MA78GM-S2HP motherboard

Donovan Lavinder drmario2007 at gmail.com
Sun Aug 21 15:00:25 CEST 2011

I decided to evict the Award BIOS for Coreboot, for some advanced features,
such as UEFI for example (upcoming BIOS won't support EFI, so I decided to
give Coreboot a shot), however, I first tried a well-known working firmware
snapshot in archived ZIP files of motherboard firmwares. For my Gigabyte
GA-MA78GM-S2HP Rev. 2.0 - I picked firmware ROM from /GIGABYTE_MA78GM/
folder, and then burned that copy onto the main firmware ROM flash chip, and
several power-downs hoping the backup BIOS won't think of silly idea of
overwriting the main firmware flash with Award BIOS. The verdict: IT WORKED!

However, I am getting rather strange behavior from WIndows XP - whenever it
boots up, it crashed (from safe mode, it stopped dead after "giveio.sys"
file was loaded - I think it could be AMD CPU driver that loads after
giveio.sys) - otherwise, Linux live CD distro (that I used to burn the
firmware) loaded fine on the computer. I am thinking it could be the bugs in

System specification:
Gigabyte GA-MA78GM-S2HP (AMD 780G / SB710 chipsets) - similar to
Gigabyte brand (can't remember model) AMD Radeon HD 4670 PCIe 2.0 1GB video
card (used as a main VGA controller)
Crucial Ballistix 2GB DDR-II 800MHz Dual-Channel kit
AMD Phenom II X4 Deneb 940 Black Series (for some reason, the firmware told
it to run at 2.0GHz instead of 3.0GHz)
Western Digital OEM Caivar 40GB SATA hard drive (WIndows XP Home Edition w/
Western Digital Caivar Blue 500GB SATA-II hard drive (secondary)
PS/2 keyboard (PS/2 mouse won't work so I am using USB mouse. An excuse for
getting all USB keyboard and mouse! :) )

"Mamma-mia, there's Koopa troopa in Mushroom Kingdom!"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20110821/ba2651f9/attachment.html>

More information about the coreboot mailing list