[coreboot] Troubles with 17'' WXGA on Roda RK886EX

Vitaly Chertovskih chertovs at gmail.com
Fri Mar 4 10:25:57 CET 2011


I've grabbed the right one vga bios with 0xae.Ignoring the seabios checksum,
it starts normally. Now, coreboot copies it into mem and i can see intel
vgabios boot logo, but it appears only on the external LCD. The problem
remains the same. Internal LCD is blank, but highlightened. On the 15'' Roda
RK8 - all is good. On my 17'' RF8 - blank screen. What shall i do?

Please, help.

Here is some log.

Coreboot init VGA:
CBFS: follow chain: fff00000 + 28 + 54f + align -> fff00580
Check pci8086,27ae.rom
In CBFS, ROM address for PCI: 00:02.0 = fff005b8
PCI expansion ROM, signature 0xaa55, INIT size 0xea00, data ptr 0x0040
PCI ROM image, vendor ID 8086, device ID 27ae,
PCI ROM image, Class Code 030000, Code Type 00
Copying VGA ROM Image from fff005b8 to 0xc0000, 0xea00 bytes
Real mode stub @00000600: 606 bytes
Calling Option ROM...
... Option ROM returned.


Seabios :


Scan for VGA option rom
Running option rom at c000:0003
unimplemented handle_155fXX:40:
   a=10005f40  b=00000011  c=00000055  d=00000000 ds=0000 es=c000 ss=0000
  si=0008c2b0 di=00000080 bp=00006efc sp=00006e6a cs=c000 ip=4bd4  f=0046
unimplemented handle_155fXX:40:
   a=00005f35  b=0000078f  c=00000002  d=000000c0 ds=c000 es=c000 ss=0000
  si=00071423 di=00000080 bp=00006efc sp=00006ed6 cs=c000 ip=4bd4  f=0046
Turning on vga text mode console

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20110304/60305e8a/attachment.html>

More information about the coreboot mailing list