[coreboot] ASUS M2V problems

G tjmadwja at gmail.com
Sat Apr 28 15:36:02 CEST 2012

On Sat, Apr 28, 2012 at 1:21 PM, ali hagigat <hagigatali at gmail.com> wrote:
> As far as I know Coreboot can not drive VGA and monitor by itself.
> There is not enough code to do that and nothing is displayed on
> monitor when you run Coreboot only.
> It only sets up some parameters regarding to VGA which will be used by
> Linux kernel later.

This seems strange to me. Besides, I've got the Coreinfo payload
working when trying out Coreboot in Qemu, so obviously there's
some VGA code somewhere that works at least when the Coreinfo
stage has been reached, but I still get nothing when flashing
Coreboot onto my bios chip.

> When you use FILO as a payload, your key-presses may be detected like
> ESC button though i did not test it myself but I found some keyboard
> manipulating code....
> On Mon, Apr 23, 2012 at 5:16 PM, G <tjmadwja at gmail.com> wrote:
>> On Mon, Apr 23, 2012 at 12:33 PM, ali hagigat <hagigatali at gmail.com> wrote:
>>> You'd better buy a debug card and plug into the PCI slot and see what
>>> numbers it will display. It has two seven segment components.
>>> Besides you can disable coreboot post codes and insert your own post
>>> codes to see how far the program runs.
>>> I did the same for my motherboard...
>> Thanks, but as I wrote on April 13th, I have managed to get some
>> output over serial, but still nothing on VGA or any response to
>> keyboard events. Details, and serial log and config file, can be
>> found in my April 13th message.

More information about the coreboot mailing list