No subject

Sun Dec 9 17:34:17 CET 2012

for the fallback image to be appended. It didn't work because you didn't
have a fallback image at the top of the flash (the end of the image file).


On Thu, 10 Apr 2003, Atherton, Stephen wrote:

> I'm trying to get etherboot and linuxbios running on a supermicro p4dpe.
> The config file I'm using is below.  It builds okay, and I get a
> romimage of around 460k (not sure why it isn't 524288), but when I burn
> it (using flash_and_burn), it doesn't seem to work.  I get no output on
> the serial port.  Note that I have BOOT_IDE set to 1 because at this
> point I would be happy just to see it boot anything, and I have linux on
> the ide hard disk.  Does BOOT_IDE do what I think it does, or is that
> for something else?  Is there something wrong with my config file, or
> should I use some other flash program for this board?  I tried the one
> from supermicro, and doesn't seem to like my romimage file, it exits
> with "cannot close filehandle".
> Also, a few other questions...
> Does linuxbios cause a beep or do anything so that when the machine is
> powered on I would have some clue that it is working?
> Since I'm using the etherboot elf image as a payload, the linux and
> commandline directives in the config file do nothing, right?
> What does USE_FALLBACK_IMAGE do exactly?
> LinuxBios Config file:
> target supermicro
> mainboard supermicro/p4dpe
> option ROM_SIZE=524288
> option ROM_IMAGE_SIZE=49152
> option TTYS0_BAUD=9600
> option TTYS0_BASE=0x3f8
> option TTYS0_LCS=0x3
> option USE_ELF_BOOT=1
> option BOOT_IDE=1
> payload ../eepro100.elf
> linux /usr/src/linux-2.4.18-14
> commandline root=/dev/hda2 console=ttyS0,9600 single

-------------------------steven james, director of research, linux labs
... ........ ..... ....                    230 peachtree st nw ste 2701
the original linux labs                    30303
      -since 1995                    
                                   office 404.577.7747 fax 404.577.7743

More information about the coreboot mailing list