[coreboot] Trying to port abit A-S78H

Prakash Punnoor prakashp at arcor.de
Tue Jan 24 17:11:15 CET 2012

On Monday 23 January 2012 22:35:22 Scott Duplichan wrote:
> Prakash Punnoor wrote:

> ]So, I cannot make coreboot boot. On cold start it seems to hang in
> ]
> ]src/southbridge/amd/sb700/reset.c
> ]
> ]in soft_reset. set_bios_reset seems sucessful, but I get no post code after
> ]outb(0x06, 0x0cf9). Any idea, what I can try?
> Maybe the reset is just causing your port 80 routing to be lost. You need
> to execute some port 80 enable and routing code as early as possible.
> Is your port 80 card PCI or LPC? For the LPC type, I believe you only
> have to set 'Port enable for IO port 80h' (bit 5 of pci config register 4Ah
> on device 14h, function 3). To route port 80 to PCI, I think you have to set
> 'IO Enable' (bit 0 of PCI config register 4 on device 14h, function 4).

Sounds reasonable. It is a PCI port 80 card. I'll try that when I find time. 
BTW, could you explain what happens after soft_reset? Will coreboot run again 
from start? At least the following "die(...)" statement (romstage.c 
cache_as_ram_main) suggests that program flow should NOT get there. So, if 
coreboots runs again from start, why doesn't it enable port 80 again like it 
did initially?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20120124/ac3d0e2a/attachment.sig>

More information about the coreboot mailing list