[coreboot] New patch to review for coreboot: 995c74c Rename bootblock init functions

Kyösti Mälkki kyosti.malkki at gmail.com
Tue Mar 20 12:58:49 CET 2012

On Mon, 2012-03-19 at 16:39 -0700, ron minnich wrote:
> we made a decision in the early days to NOT include the chip part name
> in the function names. This was not a mistake or omission, it was a
> deliberate design choice.
> The reason to name things this way is because a board is composed of a
> set of parts, and the partname is in the file name path. Hence, the
> board can be constructed of files calling functions with generic
> names, and the generic functions are provided by files chosen in the
> config. In some cases, it has proven trivial to port a mainboard to a
> new chipset by changing only the config to use a different chip. The
> fact that the function name did not include the chipname made this
> trivial.

I agree with this design. It works as the file-specific functions are
accessed only via the chip-specific _ops structure. And those structures
do have the chip name in them.

> If we think that we really need the chip name in the function, ok, but
> it's a change in the way we designed the build process. Maybe it's a
> change we have to make. I am not yet convinced.

Bootblock is special, probably for simplicity the chip objects were
dropped. BTW: There are boards with two super-ios.


More information about the coreboot mailing list