[coreboot] [RFC] mainboard.c: Unify name of device/board enable function

Paul Menzel paulepanter at users.sourceforge.net
Fri Feb 22 01:32:53 CET 2013

Dear coreboot folks,

to make the output of `diff` for `mainboard.c` smaller, Jens Rottmann
submitted a patch, to unify the name of the device enable function for
AMD Family14 boards [1].

        struct chip_operations mainboard_ops = {
        	.enable_dev = inagua_enable,

Naming this function is not uniform between the boards in the tree. AMD
based boards, seem to use *boardname*_enable, Intel boards
`mainboard_enable`. There is for example also `mb_enable` in the tree
and Jens proposed `enable_dev`.

If there are no objections to unification, what should the name for the
function be? I like Jens’ proposal as `enable_dev` is shorter than
`mainboard_enable` and it is clear that the struct member `.enable_dev`
gets set to it.

Please comment on this, so a patch can be submitted.



[1] http://review.coreboot.org/#/c/2464/1/src/mainboard/amd/inagua/mainboard.c
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20130222/6595de3c/attachment.sig>

More information about the coreboot mailing list