[coreboot] RAM speed problem on Supermicro H8QGI (Family 15h)

WANG Siyuan wangsiyuanbuaa at gmail.com
Thu Jan 24 10:03:14 CET 2013

Hi, Константин
src/mainboard/supermicro/h8qgi/buildOpts.c ?
BLDCFG_USE_HT_ASSIST can't be set as TRUE on h8qgi now. I am sorry but
I don't know how to debug this issue.

On Thu, Jan 24, 2013 at 3:42 PM, Константин Аладышев
<aladyshev at nicevt.ru> wrote:
> I have server Supermicro H8QGI board with 4 AMD Opteron f15 processors and
> 128 GB RAM (16x8Gb, 4 dimms per socket, 1 dimm per channel).
> I've tested my board in STREAM and noticed that coreboot gives RAM speed 5
> times slower than original BIOS (16 MB/s against 80 MB/s).
> What can lead to this problem?
> Is it family 15h or motherboard issue? Does another families have such
> problem?
> I've dumped registers from coreboot and original BIOS. After that i
> enabled/disabled some functions in buildOps.c to make dumps look more
> similar.
> Now dumps allmost identical (but RAM speed problem still exist).
> Also i should mention that original BIOS have HT-ASSIST feature enabled, but
> i can't enable it in coreboot
> (http://www.coreboot.org/pipermail/coreboot/2012-December/073001.html)
> But according to this link
> http://www.amd.com/us/products/server/processors/six-core-opteron/Pages/six-core-faq-ht-assist.aspx
> HT-ASSIST can increase performance by up to 60% (not 500%!). So i think it
> isn't the main problem.
> --
> coreboot mailing list: coreboot at coreboot.org
> http://www.coreboot.org/mailman/listinfo/coreboot

Yours sincerely,
WANG Siyuan

More information about the coreboot mailing list