I don't have any hardware to poke at right now :(<br><br>-Corey<br><br><div class="gmail_quote">On Thu, Oct 30, 2008 at 11:57 AM,  <span dir="ltr"><<a href="mailto:z4ziggy@gmail.com">z4ziggy@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">any plans on fixing the issue or using alternative? is there a way i can assist?<div class="Ih2E3d">
<br><br>On Oct 30, 2008 5:47pm, Corey Osgood <<a href="mailto:corey.osgood@gmail.com" target="_blank">corey.osgood@gmail.com</a>> wrote:<br>> AFAIK, flashrom is broken for most ICHx.<br>> <br>> -Corey<br>> <br>
> On Thu, Oct 30, 2008 at 9:57 AM,  <a href="mailto:z4ziggy@gmail.com" target="_blank">z4ziggy@gmail.com</a>> wrote:<br>> <br>> here is the output you've requested :<br>> <br>> <br></div><div><div></div>
<div class="Wj3C7c">> Calibrating delay loop... 366M loops per second, 100 myus = 350 us. OK.<br>> No coreboot table found.<br>> Found chipset "Intel ICH", enabling flash write... <br>> <br>> <br>
> BIOS Lock Enable: disabled, BIOS Write Enable: enabled, BIOS_CNTL is 0x1<br>> OK.<br>> Probing for AMD Am29F002(N)BB, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for AMD Am29F002(N)BT, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>
> <br>> Probing for AMD Am29F016D, 2048 KB: probe_29f040b: id1 0xff, id2 0xff<br>> Probing for AMD Am29F040B, 512 KB: probe_29f040b: id1 0x25, id2 0x81<br>> Probing for AMD Am29LV040B, 512 KB: probe_29f040b: id1 0x25, id2 0x81<br>
> Probing for ASD AE49F2008, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> <br>> Probing for Atmel AT29C020, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for Atmel AT29C040A, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>
> Probing for Atmel AT49F002(N), 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for Atmel AT49F002(N)T, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> <br>> Probing for Atmel AT25DF321, 4096 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for AMIC A25L40P, 512 KB: 4b ID not supported on this SPI controller<br>> Probing for AMIC A29002B, 256 KB: probe_29f002: id1 0xda, id2 0x32<br>> <br>> Probing for AMIC A29002T, 256 KB: probe_29f002: id1 0xda, id2 0x32<br>
> Probing for AMIC A29040B, 512 KB: probe_29f040b: id1 0x25, id2 0x81<br>> Probing for AMIC A49LF040A, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for EMST F49B002UA, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>
> <br>> Probing for EON EN29F002(A)(N)B, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for EON EN29F002(A)(N)T, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for Fujitsu MBM29F400TC, 512 KB: probe_m29f400bt: id1 0x25, id2 0x2d<br>
> <br>> Probing for Intel 82802AB, 512 KB: probe_82802ab: id1 0x25, id2 0x81<br>> Probing for Intel 82802AC, 1024 KB: probe_82802ab: id1 0x25, id2 0x81<br>> Probing for Macronix MX25L4005, 512 KB: spi_command called, but no SPI chipset/strapping detected<br>
> <br>> Probing for Macronix MX25L8005, 1024 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for Macronix MX25L1605, 2048 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for Macronix MX25L3205, 4096 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for Macronix MX29F002, 256 KB: probe_29f002: id1 0xda, id2 0x32<br>> Probing for Numonyx M25PE10, 128 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for Numonyx M25PE20, 256 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for Numonyx M25PE40, 256 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for Numonyx M25PE80, 1024 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for Numonyx M25PE16, 2048 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for PMC Pm25LV010, 128 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for PMC Pm25LV016B, 2048 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for PMC Pm25LV020, 256 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for PMC Pm25LV040, 512 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for PMC Pm25LV080B, 1024 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for PMC Pm25LV512, 64 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for PMC Pm49FL002, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for PMC Pm49FL004, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>
> Probing for Sharp LHF00L04, 1024 KB: probe_lhf00l04: id1 0x25, id2 0x81<br>> Probing for Spansion S25FL016A, 2048 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for SST SST25VF016B, 2048 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for SST SST25VF040B, 512 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for SST SST28SF040A, 512 KB: probe_28sf040: id1 0x25, id2 0x81<br>> <br>> Probing for SST SST29EE010, 128 KB: probe_jedec: id1 0xdb, id2 0x1c, id1 parity violation<br>
> Probing for SST SST29LE010, 128 KB: probe_jedec: id1 0xdb, id2 0x1c, id1 parity violation<br>> Probing for SST SST29EE020A, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> <br>> Probing for SST SST29LE020, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>
> Probing for SST SST39SF010A, 128 KB: probe_jedec: id1 0xdb, id2 0x1c, id1 parity violation<br>> Probing for SST SST39SF020A, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> <br>> Probing for SST SST39SF040, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>
> Probing for SST SST39VF512, 64 KB: probe_jedec: id1 0xff, id2 0xff, id1 parity violation<br>> Probing for SST SST39VF010, 128 KB: probe_jedec: id1 0xdb, id2 0x1c, id1 parity violation<br>> <br>> Probing for SST SST39VF020, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>
> Probing for SST SST39VF040, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for SST SST49LF002A/B, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for SST SST49LF003A/B, 384 KB: probe_jedec: id1 0xdb, id2 0x1c, id1 parity violation<br>
> <br>> Probing for SST SST49LF004A/B, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for SST SST49LF004C, 512 KB: probe_49lfxxxc: id1 0x25, id2 0x81<br>> Probing for SST SST49LF008A, 1024 KB: probe_jedec: id1 0x25, id2 0x81<br>
> <br>> Probing for SST SST49LF008C, 1024 KB: probe_49lfxxxc: id1 0x25, id2 0x81<br>> Probing for SST SST49LF016C, 2048 KB: probe_49lfxxxc: id1 0xff, id2 0xff<br>> Probing for SST SST49LF020A, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>
> <br>> Probing for SST SST49LF040, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for SST SST49LF040B, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for SST SST49LF080A, 1024 KB: probe_jedec: id1 0x25, id2 0x81<br>
> Probing for SST SST49LF160C, 2048 KB: probe_49lfxxxc: id1 0xff, id2 0xff<br>> <br>> Probing for ST M25P05-A, 64 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for ST M25P10-A, 128 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for ST M25P20, 256 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for ST M25P40, 512 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for ST M25P40-old, 512 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for ST M25P80, 1024 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for ST M25P16, 2048 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for ST M25P32, 4096 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for ST M25P64, 8192 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for ST M25P128, 16384 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for ST M29F002B, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>
> Probing for ST M29F002T/NT, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> <br>> Probing for ST M29F040B, 512 KB: probe_29f040b: id1 0x25, id2 0x81<br>> Probing for ST M29F400BT, 512 KB: probe_m29f400bt: id1 0x25, id2 0x2d<br>
> Probing for ST M29W010B, 128 KB: probe_jedec: id1 0xdb, id2 0x1c, id1 parity violation<br>> <br>> Probing for ST M29W040B, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for ST M50FLW040A, 512 KB: probe_stm50flw0x0x: id1 0xda, id2 0x32<br>
> Probing for ST M50FLW040B, 512 KB: probe_stm50flw0x0x: id1 0xda, id2 0x32<br>> <br>> Probing for ST M50FLW080A, 1024 KB: probe_stm50flw0x0x: id1 0xda, id2 0x32<br>> Probing for ST M50FLW080B, 1024 KB: probe_stm50flw0x0x: id1 0xda, id2 0x32<br>
> Probing for ST M50FW016, 2048 KB: probe_82802ab: id1 0xff, id2 0xff<br>> <br>> Probing for ST M50FW040, 512 KB: probe_82802ab: id1 0x25, id2 0x81<br>> Probing for ST M50FW080, 1024 KB: probe_82802ab: id1 0x25, id2 0x81<br>
> Probing for ST M50LPW116, 2048 KB: probe_jedec: id1 0xff, id2 0xff, id1 parity violation<br>> <br>> Probing for SyncMOS S29C31004T, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for SyncMOS S29C51001T, 128 KB: probe_jedec: id1 0xdb, id2 0x1c, id1 parity violation<br>
> Probing for SyncMOS S29C51002T, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> <br>> Probing for SyncMOS S29C51004T, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for Winbond W25x10, 128 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for Winbond W25x20, 256 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> Probing for Winbond W25x40, 512 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for Winbond W25x80, 1024 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for Winbond W29C011, 128 KB: probe_jedec: id1 0xdb, id2 0x1c, id1 parity violation<br>> <br>> Probing for Winbond W29C020C, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for Winbond W29C040P, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>
> Probing for Winbond W29EE011, 128 KB: <br>> ===<br>>   Probing disabled for Winbond W29EE011 because the probing sequence puts the<br>> <br>>   AMIC A49LF040A in a funky state.<br>>   Use 'flashrom -c W29EE011' if you have a board with this chip.<br>
> ===<br>> Probing for Winbond W39V040A, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for Winbond W39V040B, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> <br>> Probing for Winbond W39V040C, 512 KB: probe_w39v040c: id1 0xda, id2 0x32<br>
> Probing for Winbond W39V040FA, 512 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for Winbond W39V080A, 1024 KB: probe_jedec: id1 0x25, id2 0x81<br>> <br>> Probing for Winbond W49F002U, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>
> Probing for Winbond W49V002A, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for Winbond W49V002FA, 256 KB: probe_jedec: id1 0x25, id2 0x81<br>> Probing for Winbond W39V080FA, 1024 KB: probe_winbond_fwhub: vid 0xda, did 0x32<br>
> <br>> Probing for Winbond W39V080FA (dual mode), 512 KB: probe_winbond_fwhub: vid 0xda, did 0x32<br>> Probing for EON unknown EON SPI chip, 0 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for Macronix unknown Macronix SPI chip, 0 KB: spi_command called, but no SPI chipset/strapping detected<br>
> <br>> Probing for PMC unknown PMC SPI chip, 0 KB: spi_command called, but no SPI chipset/strapping detected<br>> Probing for SST unknown SST SPI chip, 0 KB: spi_command called, but no SPI chipset/strapping detected<br>
> Probing for ST unknown ST SPI chip, 0 KB: spi_command called, but no SPI chipset/strapping detected<br>> <br>> No EEPROM/flash device found.<br>> <br>> If you know which flash chip you have, and if this version of flashrom<br>
> supports a similar flash chip, you can try to force read your chip. Run:<br>> flashrom -f -r -c similar_supported_flash_chip filename<br>> <br>> <br>> Note: flashrom can never write when the flash chip isn't found automatically.<br>
> <br>> <br>> <br></div></div><div><div></div><div class="Wj3C7c">> Blessings,<br>> Elia Yehuda.<br>> <br>> <br>> On Oct 30, 2008 2:30pm, Carl-Daniel Hailfinger <a href="mailto:c-d.hailfinger.devel.2006@gmx.net" target="_blank">c-d.hailfinger.devel.2006@gmx.net</a>> wrote:<br>
> <br>> > Hi Elia,<br>> > <br>> > <br>> > <br>> > On 30.10.2008 11:45, Elia Yehuda wrote:<br>> > <br>> > > I'm trying to play with coreboot to flash my bios on my PC, with no success.<br>
> > <br>> > > here are the computer hardware information followed by the commands I'm<br>> <br>> > <br>> > > trying to execute.<br>> > <br>> > ><br>> > <br>> > > cpu:         Socket370 Intel Pentium III Celeron<br>
> > <br>> > > northbridge:    Intel 82810E<br>> > <br>> > > southbridge:    Intel 8281AA<br>> <br>> > <br>> > > mainboard:    810 R 4.1 with lan<br>> > <br>> > > super i/o:    Winbond W8362F-AW<br>
> > <br>> > > bios device:    ST M50FW002<br>> > <br>> > ><br>> > <br>> > > lspci output:<br>> > <br>> <br>> > > [...]<br>> > <br>> > ><br>> > <br>
> > > $ flashrom -f -r -c M50FW016 mydump<br>> > <br>> > > Calibrating delay loop... OK.<br>> > <br>> > > No coreboot table found.<br>> > <br>> > > Found chipset "Intel ICH", enabling flash write... OK.<br>
> <br>> > <br>> > > No EEPROM/flash device found.<br>> > <br>> > > Force read (-f -r -c) requested, forcing chip probe success:<br>> > <br>> > > Found chip "ST M50FW016" (2048 KB) at physical address 0xffe00000.<br>
> <br>> > <br>> > > Force reading flash...done<br>> > <br>> > ><br>> > <br>> > <br>> > <br>> > It is a bad sign if you had to force the chip type for the read operation.<br>
> > <br>> > <br>> > <br>> > > $ flashrom -f -w -c M50FW016 mydump<br>> <br>> > <br>> > > Calibrating delay loop... OK.<br>> > <br>> > > No coreboot table found.<br>
> > <br>> > > Found chipset "Intel ICH", enabling flash write... OK.<br>> > <br>> > > No EEPROM/flash device found.<br>> <br>> > <br>> > ><br>> > <br>> > <br>
> > <br>> > Force write can't work because the strategy for access is unknown.<br>> > <br>> > <br>> > <br>> > > I'd appreciate any assistance as all this flashing stuff is new to me.<br>
> <br>> > <br>> > > Basically what i'm trying to accomplish is having my linux system running as<br>> > <br>> > > the payload, but i'm stuck with even re-writing the same bios-dump i've just<br>
> > <br>> > > read from the bios... I'll post any further information required to diagnose<br>> <br>> > <br>> > > this further.<br>> > <br>> > ><br>> > <br>> > <br>
> > <br>> > Can you run<br>> > <br>> > flashrom -V<br>> > <br>> > and report the results to this list?<br>> > <br>> > <br>> > <br>> > We may need to change the chipset/board enable sequence for your board.<br>
> <br>> > <br>> > <br>> > <br>> > Regards,<br>> > <br>> > Carl-Daniel<br>> > <br>> > <br>> > <br>> > --<br>> > <br>> > <a href="http://www.hailfinger.org/" target="_blank">http://www.hailfinger.org/</a><br>
> > <br>> <br>> > <br>> ><br>> <br>> <br>> --<br>> <br>> coreboot mailing list: <a href="mailto:coreboot@coreboot.org" target="_blank">coreboot@coreboot.org</a><br>> <br>> <a href="http://www.coreboot.org/mailman/listinfo/coreboot" target="_blank">http://www.coreboot.org/mailman/listinfo/coreboot</a><br>
> <br>> <br>></div></div></blockquote></div><br>