<br><br><div class="gmail_quote">On Thu, Dec 18, 2008 at 5:16 PM, Marc Jones <span dir="ltr"><<a href="mailto:marcj303@gmail.com">marcj303@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div><div></div><div class="Wj3C7c">On Thu, Dec 18, 2008 at 12:10 PM, Myles Watson <<a href="mailto:mylesgw@gmail.com">mylesgw@gmail.com</a>> wrote:<br>
><br>
><br>
> On Thu, Dec 18, 2008 at 11:42 AM, coreboot information <<a href="mailto:info@coresystems.de">info@coresystems.de</a>><br>
> wrote:<br>
>><br>
>> Dear coreboot readers!<br>
>><br>
>> This is the automated build check service of coreboot.<br>
>><br>
>> The developer "myles" checked in revision 3818 to<br>
>> the coreboot source repository and caused the following<br>
>> changes:<br>
>><br>
>> Change Log:<br>
>> This patch gets rid of all the implicit definition warnings for serengeti<br>
>> except get_nodes.<br>
>><br>
>> Signed-off-by: Myles Watson <<a href="mailto:mylesgw@gmail.com">mylesgw@gmail.com</a>><br>
>> Acked-by: Marc Jones <<a href="mailto:marcj303@gmail.com">marcj303@gmail.com</a>><br>
>><br>
>><br>
>> Build Log:<br>
>> Compilation of asus:m2v-mx_se has been broken<br>
>> See the error log at<br>
>> <a href="http://qa.coreboot.org/log_buildbrd.php?revision=3818&device=m2v-mx_se&vendor=asus" target="_blank">http://qa.coreboot.org/log_buildbrd.php?revision=3818&device=m2v-mx_se&vendor=asus</a><br>

><br>
> Should this board have HAVE_HARD_RESET 1?  That fixes the build.  If not,<br>
> I'm not sure how to fix the macro definition of hard_reset in<br>
> src/include/part/hard_reset.h.  It seems strange to hang without a message,<br>
> but that's not what's causing the build failure.<br>
<br>
</div></div>Yes, I think that is the problem. It has a hard reset function in<br>
cache_as_ram_auto.c but the function is empty. Remove the function and<br>
leave the macro?</blockquote><div><br>Then the build is still broken.  The empty function says that the board should have a hard_reset, but it's not implemented.  I think the right thing to do is define HAVE_HARD_RESET and add a #warning that it isn't implemented.  Thoughts?<br>
<br>Thanks,<br>Myles<br></div></div><br>