Greetings.<br><br>I just tried the CVS coreboot v2 on my Asus P2B-LS motherboard. It's also partially working as it is similar to the already partially supported P2B-F and P3B-F, which is encouraging. There are two other boards in this series, the P2B-L and P2B-S. They share the same circuit board with -LS and only omit the SCSI or LAN (respectively), so I'll concentrate my effort on LS.<br>
<br>Let's begin with my results:<br>CPU = OK<br>L1 and L2 cache = untested<br>On-board SCSI = partial (3)<br>On-board LAN = untested<br>PS/2 keyboard still doesn't work.<br>AGP graphics card = works. Text console activated, I can see the SeaBIOS banner and text from the SCSI BIOS. On this run the card is a ATI 3D Rage IIc.<br>
Serial port 1 definitely works - see attached for a log<br>Have not tried reboot, reset button does NOT work<br><br>I am interested in helping completing support for this board. I have a POST card, a chip programmer, numerous types of PCI and AGP video cards and CPUs, which should cover a lot of grounds. (1) First I want to get RAM working, then try L2 cache, CAR if possible, keyboard/mouse, and ACPI.<br>
<br>I have some x86 assembly programming experience although I have not done much assembly coding for years, I should still be able to understand datasheets.<br><br>Before I dig right in, I want to ask what is the current state of the art for the P2B series. <br>
<br>From what I read no one actively worked on these boards for the past couple years. Our boards currently need romcc, but has anyone tried doing cache-as-RAM on these P6 CPUs?<br><br>Also to find out how the vendor initialized RAM, some analysis efforts were made on it to determine how. Will this prevent me from actually submitting a patch should I succeed? If so, can I instead post the how, and let some others code it from what I would write here?<br>
<br>I was able to get a irq routing table using coreboot's own tools.<br><br>
I already made change to my working copy to add code for "slot 1 CPUs" (duplicated from slot 2), added P2B-LS to Kconfig with aforementioned, dumped, irq routing table and related code with correct "slot 1" reference. <br>
The log above is created after these modifications are done. I also added microcode updates for family 6B1 and 6B4 CPUs but it appears coreboot isn't catching it. I run a 6B4 Tualatin on my daily desktop. My test system currently has an overclocked 6B1.<br>

<br>
<br>For starters, below is what I know.<br>On top of what a P2B carries, P2B-LS has two extra devices:<br>SCSI is on PCI 0:6.0, id 0x9005:0x001f<br>
LAN is on PCI 0:7.0, id 0x8086:0x1229<br>
In vendor BIOS the power management base port is set to 0xe400, SMBus base port is 0xe800<br>I dumped the ACPI tables from vendor bios, haven't a chance to run it through iasl yet.<br>I have seen code for doing ECC tests on memory (isn't a priority; I have no ECC memory)<br>
The RAM enable sequence is already very close to vendor's sequence.<br>PIIX4 General purpose input #21 and #13 are used<br>PIIX4 Gen Purp output #28 and #27 used<br>I/O writes to port 0xe1 is used in vendor BIOS for delays<br>
<br>Cheers<br>Keith<br><br><br>(1) My stash contains:<br>Two P2B-LS motherboards, one rev 1.04 "dot" with updated clock chip,
one rev 1.03 with updated clock and voltage chip retrofitted by yours
truly. Both have been modified slightly (2) and have vendor BIOS 1014 beta 3.<br>
One P3B-F motherboard<br>
A POST card<br>
A "Willem PCB3B" chip programmer<br>
Pentium III 450 and 600MHz in slot 1<br>
Pentium III 1000EB in S370<br>
Tualatin Celeron 1000A<br>
Tualatin Celeron 1400 in both stepping 6B1 and 6B4<br>A stick of 64MB EDO DIMM<br>Various styles of PC100 and PC133 SDRAM, a couple with 7ns time good for 140MHz, two with 6ns time claimed to be good for 150MHz<br>

<br>
(2) <a href="http://tipperlinne.com/p2bmod">http://tipperlinne.com/p2bmod</a>  These mods are done in 2003 with another enthusiast.
The objective is to have this board support every Slot 1 and Socket 370
CPUs from Klamath to Tualatin, with the right S370 adapter. I then went
on to fit PC99 color-coded connectors on both my boards.<br>
<br>
(3) I used SeaBIOS as payload and inserted the SCSI BIOS straight from vendor BIOS. It gets called, seems normal, but waits indefinitely for a keypress to enter its config screen. At this point POST card reads FE.<br>