<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:times new roman,new york,times,serif;font-size:12pt">All Opterons support ldtstop (disconnect protocol). According to the spec in x86 systems only the southbridge drives ldtstop.<br><br><div>Steve<br></div><div style="font-family: times new roman,new york,times,serif; font-size: 12pt;"><br><div style="font-family: arial,helvetica,sans-serif; font-size: 13px;"><font size="2" face="Tahoma"><hr size="1"><b><span style="font-weight: bold;">From:</span></b> Maximilian Thuermer <Maximilian.Thuermer@ziti.uni-heidelberg.de><br><b><span style="font-weight: bold;">To:</span></b> coreboot@coreboot.org; knuku@gap.upv.es<br><b><span style="font-weight: bold;">Sent:</span></b> Fri, July 2, 2010 1:25:13 AM<br><b><span style="font-weight: bold;">Subject:</span></b> [coreboot]  HTX (FPGA) device needs more time for, initialization but      HOW?<br></font><br>Hi
 Knut,<br><br>this is a problem I ran into multiple times since<br>I've been working with FPGA based HTX boards now and<br>it appears to me there is - as always - no general way to fix that issue.<br>It all depends greatly on the mobo setup. Hard reset isnt<br>always behaving as you would expect. An HT link reinitialization<br>only takes place if either pwrkok goes down (the cold reset case),<br>or ldtstop forces the link into idle state (which most Opterons<br>out there dont seem to support yet).<br>Additionally, almost every mainboard vendor ignores the fact that<br>powerok and reset_n on every HT link is defined as bidirectional.<br>I am working with a Tyan S2912 with fam10 cpus, and its MCP55 seems<br>to control abovementioned signals unidirectionally.<br>If this should be the case with your board, too, there are two possible<br>ways to fix your issue. If you have the southbridge documentation and it truly controls all HT sideband<br>signals,
 implement your own, real hard reset.<br>Another thing that works on some boards (e.g. on Tyan) is pressing and holding the reset button<br>before pressing the power button and letting it go sometimes afterwards. This holds the southbridge in init state<br>and leaves your card all the time you need to have it program itself.<br><br>Good luck and best regards,<br><br>Maximilian Thuermer<br><br><br>-- coreboot mailing list: <a ymailto="mailto:coreboot@coreboot.org" href="mailto:coreboot@coreboot.org">coreboot@coreboot.org</a><br><a href="http://www.coreboot.org/mailman/listinfo/coreboot" target="_blank">http://www.coreboot.org/mailman/listinfo/coreboot</a><br></div></div>
</div></body></html>