<br><br><div class="gmail_quote">2011/10/17 Alp Eren Köse <span dir="ltr"><<a href="mailto:alperenkose@buyutech.com.tr">alperenkose@buyutech.com.tr</a>></span><br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
Hi all,<br><br>I can't get serial output from the board I am trying to put coreboot on, so I am not able to go any further to see whats going on..<br></blockquote><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<br>The board has a Winbond W83627HF/F/HG/G (id=0x52, rev=0x41) at 0x2e.<br></blockquote><div><br>It is likely that you need to set the serial port's speed in romstage.c:<br>
<br>
// omitting includes, license header<br>
#include "superio/winbond/w83627hf/early_serial.c"<br>
#define SERIAL_DEV PNP_DEV(0x2e, W83627HF_SP1)<br>
<br>
Add this line to main():<br>
w83627hf_set_clksel_48(SERIAL_DEV);<br> <br></div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<br>I couldn't figure out where to put the "chip superio/winbond/w83627hf" section in the "devicetree.cb" file layout?<br></blockquote><div><br>SCH boards don't use the serial port but the EHCI debug port to show output on? See src/mainboard/iwave/iWRainbowG6/devicetree.cb, it doesn't have the superio included.<br>
</div><div><br>What I would do is put it inside the LPC bridge section, note that I don't know how the superio is actually attached and therefore could be wrong.<br>So:<br>        chip southbridge/intel/i82801ex<br>            device pci 1f.0 on # lpc bridge<br>
                chip superio/winbond/w83627hf<br>                end # superio<br>            end # 1f.0<br><br> <br></div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
Could someone please explain the devicetree.cb file structure? or point a way?<br>
<br>The "lspci -tvnn" output and my modified "devicetree.cb" file are at the attachment.<br><br>Thanks in advance,<br><font color="#888888">Alp<br>
</font><br>--<br>
coreboot mailing list: <a href="mailto:coreboot@coreboot.org">coreboot@coreboot.org</a><br>
<a href="http://www.coreboot.org/mailman/listinfo/coreboot" target="_blank">http://www.coreboot.org/mailman/listinfo/coreboot</a><br></blockquote></div><br>