<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=koi8-r" http-equiv=Content-Type>
<META name=GENERATOR content="MSHTML 8.00.6001.19394">
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT size=3 face=Arial><PRE>I have server Supermicro H8QGI board with 4 AMD Opteron f15 processors and 128 GB RAM (16x8Gb, 4 dimms per socket, 1 dimm per channel).</PRE><PRE>I've tested my board in STREAM and noticed that coreboot gives RAM speed 5 times slower than original BIOS (16 MB/s against 80 MB/s). </PRE><PRE>What can lead to this problem?</PRE><PRE>Is it family 15h or motherboard issue? Does another families have such problem?</PRE><PRE>I've dumped registers from coreboot and original BIOS. After that i enabled/disabled some functions in buildOps.c to make dumps look more similar.</PRE><PRE>Now dumps allmost identical (but RAM speed problem still exist). </PRE><PRE>Also i should mention that original BIOS have HT-ASSIST feature enabled, but i can't enable it in coreboot (<A href="http://www.coreboot.org/pipermail/coreboot/2012-December/073001.html">http://www.coreboot.org/pipermail/coreboot/2012-December/073001.html</A>)</PRE><PRE>But according to this link <A href="http://www.amd.com/us/products/server/processors/six-core-opteron/Pages/six-core-faq-ht-assist.aspx">http://www.amd.com/us/products/server/processors/six-core-opteron/Pages/six-core-faq-ht-assist.aspx</A> HT-ASSIST can increase performance by up to 60% (not 500%!). So i think it isn't the main problem.</PRE></FONT></DIV></BODY></HTML>