[flashrom] #1: flashRom doesn't work on MotherBoard with ICH9 + MP2532

flashrom svn at flashrom.org
Tue Aug 25 09:11:47 CEST 2009

#1: flashRom doesn't work on MotherBoard with ICH9 + MP2532
   Reporter:  annyvonne.le_coq@…                  |          Owner:  hailfinger    
       Type:  defect                              |         Status:  assigned      
   Priority:  major                               |      Milestone:  flashrom 0.9.1
  Component:  flashrom                            |        Version:                
   Keywords:                                      |   Dependencies:                
Patchstatus:  there is no patch                   |  

Comment(by anonymous):

 Replying to [comment:4 hailfinger]:
 > There are 3 issues:
 > * ICH9 PCI ID was not recognized. Fixed in r696.
 > * Complains about opcode 0x06. I have a fix with correct PREOP handling,
 but this does not cause any problems except for lots of log output.
 > * Transaction errors for opcode 0x03. This is actually three different
 >  * We forget to clear the transaction error flag after a transaction
 error happens. Patch for this is upcoming.
 >  * The chipset does not allow us to read some areas of the chip. No idea
 why (maybe region protection in ICH9?)
 >  * We don't abort after the first read error. Needs to be fixed.

 You're right: an area is write protected by ICH9 due to current BIOS
 initialization. It's possible to read this descriptor in flash address 0
 (offset 60H).
 As the descriptor can be written by flashrom -r, I patch it and reload it
 by flashrom -w.
 Then, I must reboot so that modifications are taken into account by ICH9.
 After this reboot, it's possible to re-write the entire flash.

Ticket URL: <http://www.flashrom.org/trac/flashrom/ticket/1#comment:5>
flashrom <http://www.flashrom.org/>

More information about the flashrom mailing list