Difference between revisions of "Board:gigabyte/m57sli"

From coreboot
Jump to navigation Jump to search
m (→‎Status: Updates and fixes.)
Line 17: Line 17:


|CPU_status = OK
|CPU_status = OK
|CPU_comments =  
|CPU_L1_status = Untested
|CPU_L2_status = Untested
|CPU_L3_status = N/A
|CPU_multiple_status = N/A
|CPU_multiple_status = N/A
|CPU_multicore_status = OK
|CPU_multicore_status = OK
|CPU_virt_status = Untested
|RAM_EDO_status = N/A
|RAM_EDO_status = N/A
|RAM_SDRAM_status = N/A
|RAM_SDRAM_status = N/A
|RAM_SODIMM_status = N/A
|RAM_SODIMM_status = N/A
|RAM_DDR_status = N/A
|RAM_DDR_status = N/A
|RAM_DDR2_status = OK
|RAM_DDR2_status = OK
|RAM_DDR2_comments =
|RAM_DDR3_status = N/A
|RAM_DDR3_status = N/A
<!-- Uwe: Does the board really have DDR2? Or DDR? -->
<!-- hg87: This board has really DDR2! -->
|RAM_dualchannel_status = OK
|RAM_dualchannel_status = OK
|RAM_dualchannel_comments = According to memtest86+ it works.
|RAM_dualchannel_comments = According to memtest86+ it works.
|RAM_ecc_status = Untested


|IDE_status = OK
|IDE_status = OK
|IDE_comments =
|Onboard_modem_status = N/A
|IDE_25_status = N/A
|IDE_25_status = N/A
|IDE_25_comments =
|IDE_CF_status = OK
|IDE_CF_status = OK
|IDE_CF_comments = Tested with an CF-IDE adapter without DMA support. Booting with LinuxBIOS is no problem. Booting with propritary BIOS didn't work.
|IDE_CF_comments = Tested with an CF-IDE adapter without DMA support. Booting with LinuxBIOS is no problem. Booting with propritary BIOS didn't work.
|CDROM_DVD_status = OK
|CDROM_DVD_status = OK
|DiskOnChip_status = N/A
|DiskOnChip_comments =
|SATA_status = OK
|SATA_status = OK
|SATA_comments = A FILO patch is needed (see below) as LinuxBIOS is too fast and the disks have not spun up yet when LinuxBIOS is done.
|SATA_comments = A FILO patch is needed (see below) as LinuxBIOS is too fast and the disks have not spun up yet when LinuxBIOS is done.
|USB_status = OK
|USB_status = OK
|USB_comments = Tested: mounting USB storage devices and accessing files on them. USB MIDI-keyboard works, too (keyboard == the music instrument, in this case).
|USB_comments = Tested: mounting USB storage devices and accessing files on them. USB MIDI-keyboard works, too (keyboard == the music instrument, in this case).
|Onboard_VGA_status = N/A
|Onboard_VGA_status = N/A
|Onboard_VGA_comments =
|Onboard_ethernet_status = OK
|Onboard_ethernet_status = OK
|Onboard_ethernet_comments =
|Onboard_audio_status = OK
|Onboard_audio_status = OK
|Onboard_audio_comments = Use '''modprobe snd-hda-intel''' (Alsa).
|Onboard_audio_comments = Use '''modprobe snd-hda-intel''' (Alsa).
|Onboard_firewire_status = Needs testing
|Onboard_modem_status = N/A
|Onboard_firewire_status = Untested
|Onboard_firewire_comments = PCI 01:0a.0 (FireWire) shows up in lspci as of r2921, but needs testing.
|Onboard_firewire_comments = PCI 01:0a.0 (FireWire) shows up in lspci as of r2921, but needs testing.
|Smartcard_status = N/A
|Onboard_CF_status = N/A
|Onboard_CF_status = N/A
|Onboard_PCMCIA_status = N/A
|Onboard_PCMCIA_status = N/A
|AMR_cards_status = N/A
|AMR_cards_status = N/A
|ISA_cards_status = N/A
|PCI_cards_status = WIP
|PCI_cards_status = WIP
|PCI_cards_comments = as of r2921 PCI 01:07.0 appears fully functional; PCI 01:08.0 (closer to the board edge) shows up in lspci, but no interrupts yet.
|PCI_cards_comments = As of r2921 PCI 01:07.0 appears fully functional; PCI 01:08.0 (closer to the board edge) shows up in lspci, but no interrupts yet.
 
|AGP_cards_status = N/A
|PCIE_cards_status = OK
|PCIE_x1_status = Unknown
|PCIE_cards_comments = Tested with a PCI Express VGA card.
|PCIE_x2_status = N/A
 
|PCIE_x4_status = N/A
|PCIE_x8_status = N/A
|PCIE_x16_status = OK
|PCIE_x16_comments = Graphics card works (but not with the propritary nVidia driver right now).
|PCIE_x32_status = N/A
|HTX_status = N/A
|HTX_status = N/A
|HTX_comments =


|Floppy_status = No
|Floppy_status = No
|Floppy_comments = Should work, but doesn't.
|Floppy_comments = Should work, but doesn't.
|COM1_status = OK
|COM1_status = OK
|COM1_comments = Serial console for LinuxBIOS and Linux is fully operational.
|COM1_comments = Serial console for LinuxBIOS and Linux is fully operational.
|COM2_status = N/A
|COM2_status = N/A
|COM2_comments =
|PP_status = OK
 
|PP_status = Untested
|PP_comments = Doing '''modprobe parport parport_pc''' works, but no further tests were done.
|PP_comments = Doing '''modprobe parport parport_pc''' works, but no further tests were done.
|PS2_keyboard_status = OK
|PS2_keyboard_status = OK
|PS2_keyboard_comments = Validated when booting with a PCIe VGA card under FILO and Linux; LinuxBIOS logs an error ("keyboard init failed") but this is not critical.
|PS2_keyboard_comments = Validated when booting with a PCIe VGA card under FILO and Linux; LinuxBIOS logs an error ("keyboard init failed") but this is not critical.
|PS2_mouse_status = OK
|PS2_mouse_status = OK
|PS2_mouse_comments =
|Game_port_status = Untested
|IR_status = Untested
|Speaker_status = OK
|Speaker_comments = Works with '''beep''' (use '''modprobe pcspkr''').
|DiskOnChip_status = N/A


|Sensors_status = OK
|Sensors_status = OK
|Sensors_comments = Sensors and fans work, see [http://linuxbios.org/pipermail/linuxbios/2007-April/020230.html instructions]. Some sensor readouts are off, and the pwm polarity seems to be inverted, but fan speed can be set.
|Sensors_comments = Sensors and fans work, see [http://linuxbios.org/pipermail/linuxbios/2007-April/020230.html instructions]. Some sensor readouts are off, and the pwm polarity seems to be inverted, but fan speed can be set.
 
|Watchdog_status = Untested
|Speaker_status = OK
|CAN_bus_status = N/A
|Speaker_comments = Works with '''beep''' (use '''modprobe pcspkr''').
 
|CPUfreq_status = No
|CPUfreq_status = No
|CPUfreq_comments = Won't work as long as there's no ACPI implementation for this board.
|CPUfreq_comments = Won't work as long as there's no ACPI implementation for this board.
 
|Powersave_status = Untested
|Smartcard_status = N/A
|ACPI_status = No
|Smartcard_comments =
 
|ISA_cards_status = N/A
|ISA_cards_comments =
 
|AGP_cards_status = N/A
|AGP_cards_comments =
 
|PCIE_x1_status = Unknown
|PCIE_x1_commments =
 
|PCIE_x2_status = N/A
|PCIE_x2_commments =
 
|PCIE_x4_status = N/A
|PCIE_x4_commments =
 
|PCIE_x8_status = N/A
|PCIE_x8_commments =
 
|PCIE_x16_status = OK
|PCIE_x16_comments = Graphics card works (but not with the propritary nVidia driver right now).
 
|PCIE_x32_status = N/A
|PCIE_x32_commments =
 
|Flashrom_status = OK
|Flashrom_comments = As of revision 2958, [[Flashrom]] now works under LinuxBIOS if you have a plcc version of this board. Flashrom works fine under the proprietary BIOS. SPI flashing support is on its way, but not 100% there yet.
|Reboot_status = OK
|Reboot_status = OK
|Poweroff_status = No
|Poweroff_status = No
|LEDs_status = OK
|LEDs_status = OK
|LEDs_comments = HD-LED works. Power-LED untested.
|LEDs_comments = HD-LED works. Power-LED untested.
|HPET_status = Untested
|RNG_status = Untested
|WakeOnModem_status = Untested
|WakeOnLAN_status = Untested
|WakeOnKeyboard_status =Untested
|WakeOnMouse_status = Untested
|Flashrom_status = OK
|Flashrom_comments = As of revision 2958, [[Flashrom]] now works under LinuxBIOS if you have a PLCC version of this board. Flashrom works fine under the proprietary BIOS. SPI flashing support is on its way, but not 100% there yet.
}}
}}



Revision as of 15:08, 15 November 2007