[coreboot] current dtc patch

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sat Sep 6 04:57:57 CEST 2008


On 05.09.2008 22:45, ron minnich wrote:
> On Fri, Sep 5, 2008 at 1:39 PM, Carl-Daniel Hailfinger
> <c-d.hailfinger.devel.2006 at gmx.net> wrote:
>   
>> On 05.09.2008 22:22, Carl-Daniel Hailfinger wrote:
>>     
>>> On 04.09.2008 18:04, ron minnich wrote:
>>>
>>>       
>>>> no ack in it, for your viewing pleasure.
>>>>
>>>> Tested on dbe62.
>>>>
>>>>
>>>>         
>>> Looks nice.
>>> Acked-by: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006 at gmx.net>
>>>
>>>       
>> It exploded with the current dts of the AMD Serengeti, though, and
>> produced this statictree.c excerpt:
>>     
>>> struct device dev_ioport_2e = {
>>>         .path = {{.type=DEVICE_PATH_IOPORT,{.ioport={.iobase=0x2e}}},
>>>       
>> One opening bracket too many.
>>
>>     
>>>         .device_configuration = &ioport_2e,
>>>         .next = &dev_domain_0,
>>>         .links = 0,
>>>         .bus = &dev_domain_0.link[0],
>>>         .next = &dev_domain_0,
>>>         .dtsname = "ioport_2e",
>>>         .enabled = 1
>>> };
>>>       
>> Regards,
>> Carl-Daniel
>>
>> --
>> http://www.hailfinger.org/
>>
>>
>>     
>
> yeah my bad I fixed that.
>   

Oh, and another bug: The statictree.c code now refers to nonexisting
links. Look at this snippet:
struct device dev_root = {
        .path = { .type = DEVICE_PATH_ROOT },
        .next = &dev_cpu_0,
        .links = 0,
        .bus = &dev_root.link[0],
        .next = &dev_cpu_0,
        .ops = &default_dev_ops_root,
        .dtsname = "root",
        .enabled = 1
};
struct device dev_cpu_0 = {
        .path = {.type=DEVICE_PATH_CPU,{.cpu={ .id = 0x0 }}},
        .sibling = &dev_apic_0,
        .next = &dev_apic_0,
        .links = 0,
        .bus = &dev_root.link[0],   //DOES NOT EXIST
        .next = &dev_apic_0,
        .dtsname = "cpus",
        .enabled = 1
};


Maybe using my patch is really the better choice. I'll admit anytime
that my naming scheme is overly verbose and you're free to change it.

Regards,
Carl-Daniel

-- 
http://www.hailfinger.org/





More information about the coreboot mailing list