[coreboot] [PATCH] flashrom patch easier board_pciid_enables parsing
peter at stuge.se
Wed Jan 14 00:33:31 CET 2009
ron minnich wrote:
> >> Similarly to flashchips array, this patch intends to make the
> >> table board_pciid_enables more readable.
> > For certain versions of readable. What real problem does this solve?
> 1. Next time someone adds a new struct member, we avoid mistakes of
> ordering of initializers
> 2. we avoid mistakes in the first place.
> The .x = y stuff was added for a (good) reason, I think this is an
> Acked-by: Ronald G. Minnich <rminnich at gmail.com>
Sorry, but I really do not like these at all and I would much rather
see the chip table change back. There seemed to be general agreement
about that on IRC the other day as well.
If a mistake sneaks into the structs it will be trivial to fix..
More information about the coreboot