[coreboot] [commit] r6497 - in trunk/src/arch/x86: . init

repository service svn at coreboot.org
Thu Apr 14 22:30:22 CEST 2011


Author: stepan
Date: Thu Apr 14 22:30:21 2011
New Revision: 6497
URL: https://tracker.coreboot.org/trac/coreboot/changeset/6497

Log:
- drop remaining CONFIG_ROM_IMAGE_SIZE
- re-enable .data section check for bootblock.
- rename ldscript_fallback_cbfs.lb to bootblock.ld

Signed-off-by: Stefan Reinauer <stefan.reinauer at coreboot.org>
Acked-by: Stefan Reinauer <stefan.reinauer at coreboot.org>

Added:
   trunk/src/arch/x86/init/bootblock.ld
      - copied, changed from r6491, trunk/src/arch/x86/init/ldscript_fallback_cbfs.lb
Deleted:
   trunk/src/arch/x86/init/ldscript_fallback_cbfs.lb
Modified:
   trunk/src/arch/x86/Makefile.inc

Modified: trunk/src/arch/x86/Makefile.inc
==============================================================================
--- trunk/src/arch/x86/Makefile.inc	Thu Apr 14 22:21:49 2011	(r6496)
+++ trunk/src/arch/x86/Makefile.inc	Thu Apr 14 22:30:21 2011	(r6497)
@@ -165,7 +165,7 @@
 
 crt0s = $(src)/arch/x86/init/prologue.inc
 ldscripts =
-ldscripts += $(src)/arch/x86/init/ldscript_fallback_cbfs.lb
+ldscripts += $(src)/arch/x86/init/bootblock.ld
 ifeq ($(CONFIG_BIG_BOOTBLOCK),y)
 crt0s += $(src)/cpu/x86/16bit/entry16.inc
 ldscripts += $(src)/cpu/x86/16bit/entry16.lds

Copied and modified: trunk/src/arch/x86/init/bootblock.ld (from r6491, trunk/src/arch/x86/init/ldscript_fallback_cbfs.lb)
==============================================================================
--- trunk/src/arch/x86/init/ldscript_fallback_cbfs.lb	Wed Apr 13 11:23:45 2011	(r6491, copy source)
+++ trunk/src/arch/x86/init/bootblock.ld	Thu Apr 14 22:30:21 2011	(r6497)
@@ -29,7 +29,7 @@
 
 	/* cut _start into last 64k*/
 	_x = .;
-	. = (_x < (CONFIG_ROMBASE - 0x10000 +  CONFIG_ROM_IMAGE_SIZE)) ? (CONFIG_ROMBASE - 0x10000 +  CONFIG_ROM_IMAGE_SIZE) : _x;
+	. = (_x < CONFIG_ROMBASE) ? (CONFIG_ROMBASE) : _x;
 
 	/* This section might be better named .setup */
 	.rom . : {
@@ -49,6 +49,5 @@
 		*(.comment.*)
 		*(.note.*)
 	}
-/*	_bogus = ASSERT((SIZEOF(.bss) + SIZEOF(.data)) == 0, "Do not use global variables in romstage"); */
-	_bogus = ASSERT((SIZEOF(.bss)) == 0, "Do not use global variables in romstage"); 
+	_bogus = ASSERT((SIZEOF(.bss) + SIZEOF(.data)) == 0, "Do not use global variables in romstage");
 }




More information about the coreboot mailing list